Web Essentials 2012

Free

Adds many useful features to Visual Studio for web developers.

(190) Review
Visual Studio
2012
Download (1,008,065)
2/25/2014
3.7
View
E-mail Twitter del.icio.us Digg Facebook
Add to favorites
Description
Reviews (190)
Q and A (317)
Sign in to write a review
Sort by:

by Bob Blork | May 30 2014

nice!

by Shreeharsh Ambli | April 17 2014

brings in new capabilities

by Ilya Galakhov | February 19 2014

Thank You!

by Jitbit1 | February 04 2014

No more LESS support in the latest version. But "LESS" is there on the product page, there's even a LESS-settings tab in the options. Thanks for ruining our work process.

This extension is #1 result in Google for "Visual Studio LESS".

PS. the new "ASP.NET and Web Tools 2012.2" only highlights LESS code, but does not compile it!! So your answer does not help!!

by Proco | January 27 2014

Amazing extension!

by Richard D | December 19 2013

Nice tools, but unfortunately Typescript is left out of the recent update. So a lot of the functionality I used is not available anymore.

:-(

by harwi | November 30 2013

Great tool!

by Breno Queiroz | November 27 2013

You Must Have It!

by Balaji M Kundalam | November 23 2013

Useful add on.

by GK Dev | November 20 2013

by TW Scannell | November 19 2013

This says is updated today.It fails to install in VS 2012 Express

Mads Kristensen November 20 2013
| Edit |
Delete

Unfortunately, VS Express doesn't support 3rd party extension. It's not a limitation of Web Essentials

by Eliezer Perlmutter | November 01 2013

by Leonardo Lourenço Silva | November 01 2013

Very USeful !!!

by Christiaan Rakowski | October 28 2013

by HiTech Magic | October 22 2013

Dropping support for TypeScript (without plastering that "little" detail all over the download page) has just cost me 4 wasted hours and sent me full circle back to the old Web Essentials.

1. Installed Web essential update
- lost TypeScript support

2. Installed separate TypeScript add-in from MS
- Does not build existing TypeScript files in project

3. Researched how to modify project to get it to build TypeScript files
- Still does not build existing TypeScript files in project

4. Created a new project minimal testbed to test TypeScript compiling
- ts files are added, with TypeScriptCompile option, but do not generate .js files at all. Tools | Options etc have no effect

5. Researched this new problem
- Gave up in disgust

6. Uninstalled TypeScript & latest Web Essentials

7. Installed old Web Essentials
- Luckily this was still in my download folder

8. Have now lost color-coding, intellisense and all those other features that made Web Essentials useful.
- Decide to write grumpy review :(

I have never had so much grief from one update. In future I will Google for problems with the updates before even thinking about pressing upgrade!

by Cattousa | October 15 2013

WebEssentials 2012 is a stellar extension. Being able to collapse JavaScript between {curly brackets} is very useful.

by Ytrog | October 15 2013

Good plugin although the CoffeeScript functionality doesn't compile the scripts and crashes vs2012 every time I try :(

by Aleksandar Totovic | October 08 2013

It's very nice

by Kijana Woodard | October 04 2013

Overall nice, but last update broke markdown support in VS2012. I can't edit the files anymore. Having to use npp++. :-[

Mads Kristensen October 05 2013
| Edit |
Delete

This is now fixed in version 3.2

by dirq | October 02 2013

Love it. All the things missing in Visual Studio are right here. You need this.

1 - 20 of 190 Items   
Sign in to start a discussion


  • Still Hangs with 1.9.1...
    14 Posts | Last post November 30, 2012
    • Opening a solution with last .js file opened still causes hang with 1.9.1.
    • Try turning off JSHint and let me know if it still reproduces. I have a hard time reproducing this particular issue, though other people have reported it too.
    • Try this build: http://madskristensen.net/custom/webessentials2012.vsix?1.9.1.3
    • Nope, neither works.
      
      I manage to reproduce this issue very easily:
      - Create/open an ASP.NET web project that contains .js files
      - Open any .js file in the editor
      - Close solution and VS
      - Open VS and open solution
      - VS hangs when opening it as it seems the last opened .js file causing it to hang with Web Essentials enabled
    • i confirm too, the Solution Hangs even with 1.9.1
      
      
    • Do you have any other extensions installed. ReSharper and/or others? I'm beginning to think it could be caused by a conflict of extensions
    • Actually, try to go to Tools -> Options -> Web Essentials -> JavaScript. Then turn all the settings to "False" and see if that helped.
    • Suspending ReSharper didn't seem to help my problem with this. 
      
      I then disabled Productivity Power Tools and .NET Demon (from RedGate) and it loaded up fine. I then tried to re-enable one or the other to see if that fixed the problem. 
      
      Re-enabling .NET Demon caused the problem to recur. I then flipped and disabled .NET Demon and enabled Productivity Power Tools, and the problem was also recurring (but the freeze seemed to happen at a different point and triggered a prevention of document load).
      
      So, at that point, with both .NET Demon and Productivity Power Tools disabled, I told ReSharper to resume. And it loaded up fine without a hang with the .js file open.
    • Thanks for the detailed description. I use Productivity Power Tools and can't repro. I'll try .NET demon. What OS are you running? Also, what VS profile are you using (C#, General settings, Web developer (code only) or...? 
      
    • Btw, can you try this build and see if the problem is fixed? htp://madskristensen.net/custom/webessentials2012.vsix?1.9.1.5
    • Re-enabled both of those extensions and the new version you just posted seems to have fixed the problem.
    • I've seen this behaviour too, but to me it seemed more like VS's or the TS plugin's fault. It happened on loading a project in VS, while there was a code issue in the accompanying TS file. Changing the TS file extension allowed me to load my project and look for the problem. If I recall correctly, I had a faulty Type assignment and VS gets stuck on this... but only straight after opening the solution / project. 
    • Seems this has been fixed in 1.9.2. Thanks.
      
      Just curious, what actually went wrong previously?
    • It was a threading issue when calling DTE.StatusBar.Text = "something"
      
      The strange thing about it is that it didn't repro at all on any of my machines, so that's why I couldn't quickly fix it - I simply didn't know what caused the hang. Some friendly souls on Twitter helped me with stack traces that let me down the right path.
  • "Find References" for JS not working
    3 Posts | Last post November 30, 2012
    • On the most recent version (1.9.1), I can hit shift-F12 on a CSS selector, and it does a "Find in Files" for that element (though I think *.cshtml should be included in that search by default).  However, when I try that in a JS file, it never seems to do anything.  Is there another command to use in a JS file?
    • Try this latest build http://madskristensen.net/custom/webessentials2012.vsix?1.9.1.4
    • Sorry, I didn't see the reply in time to beat 1.9.2 to production, but I can confirm that it's working perfectly in 1.9.2.
      
      Thanks!
      J
  • BUG: Copying and pasting a Typescript class freezes VS
    1 Posts | Last post November 30, 2012
    • When I copy and paste a class inside of a TS file it causes Visual Studio to lock up and I have to kill VS and open it again. I just encoutered this twice in a row using 1.9.2.
  • Vendor-prefixes for property values
    1 Posts | Last post November 30, 2012
    • Vendor prefix management is great, except I'm finding a few cases where it causes me more work.
      
      1. box-shadow and border-radius are supported by firefox/chrome. Every time I add vendor specific prefixes with this ext, I have to go through and manually remove all of the extra box-shadow/border-radius entries.
      
      2. Vendor-specific prefixes in property values are not translated. e.g.:
      
      .myClass
      {
         transition: transform 1s;
      }
      
      should turn in to, e.g.:
      
      -webkit-transition: -webkit-transform 1s;
      
      but instead it turns into
      
      -webkit-transition: transform 1s;
      
      which is meaningless to webkit.
      
      
      This also happens with the "calc" property value as well--rather this value is simply not supported.
      
      e.g. 
      .myItem
      {
         max-width: calc(100% - 40px);
      }
      
      should get
      
      max-width: -webkit-calc(100% - 40px);
      max-width: -moz-calc(100% - 40px);
      
      But there is no support for this.
  • Tools/Options not appearing for WebEssentials
    3 Posts | Last post November 29, 2012
    • Had a problem with VS and was forced to repair the install.  Since then I have not had Web Essentials Tools/Option menu.  Tried uninstall / re-install of WE, but have not been able to repair it.
      
      Thoughts?  Tips/Tricks on forcing VS to really re-install?
      
      Love the TS 
    • Try this from the command line:
      
      devenv.exe /setup
    • Nope - Still no luck.
      Even uninstalling / reinstalling VS 2012 and no luck.
      The original problem seemed to coincide with the install of VS 2012 Update 1
      
      Where is VS keeping it's plugins state - is there something that I can do to really wipe the slate clean?
  • Object Literals & Collapsing
    2 Posts | Last post November 29, 2012
    • I have a really large jQuery widget that I maintain:
      
      $.widget('gordian.grid2', {
         func1 : function () {
      
         },
      
         //etc.,
      
         options: {
            // just a json object literal, no functions, etc. Just literal values
         }
      });
      
      Well, before 1.9.1, the options portion wouldn't collapse at all. Which was SUPER annoying. It's really long.  Now it collapses. Yay!
      
      But, it collapses all the way down to the }); line, rather than the } line, which actually closes the options literal.
    • More detail:
      
      $.widget('gordian.grid2', {
         func1 : function () {
      
         },
      
         //etc.,
      
         options: {
            defaultSortField: null,
            //etc.,
            actionButtons: { }
         }
      });
      
      Causes the above problem.  Fix it to this:
      $.widget('gordian.grid2', {
         func1 : function () {
      
         },
      
         //etc.,
      
         options: {
            defaultSortField: null,
            //etc.,
            actionButtons: { 
            
            }
         }
      });
      
      And boom, it works as expected.
  • TypeScript - Receive Compile Error if all referenced Files are not checked out
    7 Posts | Last post November 29, 2012
    • Just downloaded v1.9.1.  I restructed my Code (no I generate a Bundle File) for each "Folder".
      
      But, now I receive this error in the Preview Window when saving TS File.  I do not generate all TS Files on "Build".  I do generate on "Save".
      
      But, there are no "Errors" listed in my Error Window.
      
      Preview Window: 
      
      /*
      Compile Error.
      See error list for details
      */
    • In latest build, I've made it so the error is always displayed in the preview window. Give it a try: http://madskristensen.net/custom/webessentials2012.vsix?1.9.1.1
    • Ok, no the Error says:
      
      "tsc.js (23778, 29) Microsoft JScript Runtime error: Write to file failed."
      
      I've checked out all Files in the Folder where I'm editing the TS File because I have a js.bundle File now and figured this was the File that is was trying to write too, but that doesn't help. I MUST check out all "Referenced" Files first.
      
      
    • What type of source control system are you using? Any source control system that integrates into VS will have the files automatically checked out by Web Essentials. 
    • I receive the "Microsoft JScript Runtime error: Write to file failed" if I do not first compile as referenced .ts script files first.
      
      So say I have a file Mads.ts:
      
      /// <reference path="../Human.ts" />
      class Mads extends Human
      ...
      
      I need to first save Human.ts to compile it, then switch to Mads.ts and then save it and it compiles ok at that point.
      
      I have been using this workaround for a few of the last nightly builds.
      
      My workflow is to compile on save with the preview window up, and source map generation.
      
      FYI - I was able to debug .ts files in Chrome yesterday (with source maps enabled)!
      
      
      
      
    • I'm using TFS 2010 for my Source Control with VS 2012 Ultimate.
    • One more thing. I'm using TFS 2010 and in Visual Studio I DO NOT automatically check-out files. We prompt for Check-Out. 
      
      Also, what File(s) is it trying to check out?? There is no need to check out other TS Files from other Folders correct?  I'm only making changes to files in my Folder and since I've setup a JS Bundle File for that Folder, I'd assume that it would need to check out the JS Bundle File so it can auto re-compile on save.
  • JSHint disabling doesn't work?
    4 Posts | Last post November 29, 2012
    • I updated the plugin yesterday to the latest version and noticed that when I load a .js file, JSHint is run on the file even if I have the Enable JSHint setting turned to False. Since my team is using JSLint, I'm getting errors I can't turn off. Did something change to how the JSHint setting is detected?
    • Oh man. I just released version 1.9 and didn't see this bug. I've got a fix for it now, so send and email to madsk at Microsoft com and I'll send you updated bits. Sorry!
    • It's not super critical for me, I'm ok waiting for it to get into an official build, just thought I'd report it. Though I'm a bit surprised I don't see the fix in 1.9.1, since that was just released.
    • Nevermind, it does appear to have made 1.9.1 - JSHint was just reenabled when I updated, it appears.
  • Code behind for generated files
    3 Posts | Last post November 29, 2012
    • Hi Mads,
      
      According to this uservoice suggestion http://webessentials.uservoice.com/forums/140520-general/suggestions/3231443-code-behind-for-generated-files the .css files generated from a .less file should be shown as 'code behind' file. Do I need to turn on some setting to make this happen? 
      
      We're using web site projects in which this does not work. When creating a .less file a .css and .min.css file is automatically created, but neither is 'hooked' to the original .less file
      
      You can imagine that with about 5-10 includes this turns into a large number of .css files...
    • This, unfortunately, doesn't work for website project. I've talked to the project system team and they want to fix this for the next version of Visual Studio.
    • And by next version I suppose you mean VS2015 or something of the sorts? Or more like SP1 for VS2012? Could be a very long wait otherwise :s
  • WE Squiggles - version 1.9.1
    2 Posts | Last post November 29, 2012
    • With
        input:focus {
          outline: none;
        }
      
      "outline" gets a squiggle with tooltip "Add missing vendor specific properties to 'outline' (-moz)"
      
      This turns it into
        input:focus {
          -moz-outline: none;
          outline: none;
        }
      
      Now -moz-outline: none is squiggled, with a tooltip "-moz-outline is deprecated and is safe to remove".
      
      So, I delete it and we go back to the first situation (and squiggle).
      
      
      
    • That is very strange. I can't reproduce it. It sounds like a weird condition of mixed schema files being applied. Try go to this folder and delete the "css" folder.
      
      C:\Users\[username]\AppData\Roaming\Microsoft\VisualStudio\11.0\schemas
      
      After restarting VS, Web Essentials should go out and retrieve the latest css schema files and recreate the "css" folder.
201 - 210 of 317 Items