Mindscape Web Workbench

Free

Accelerate and simplify your Web development experience with Visual Studio integrated Sass, Less and CoffeeScript support

(76) Review
Visual Studio
2013, 2012, 2010
Download (209,240)
6/19/2014
3.3.1608
View
E-mail Twitter del.icio.us Digg Facebook
Add to favorites
Description
Reviews (76)
Q and A (26)
Sign in to write a review
Sort by:

by Marcel Härri | Wed 12:48 PM

the free Version does not compile less to css,
so what's so cool with it, the splitted window
without functionality or the begging for Money bubble?
what does the paid Version? remove the bubble?
Please don't fool me, that's less than useless.

by nire0510 | June 23 2014

Great one. Pity that SASS version is not up-to-date.

To update SASS version on your own, save the following lines in a batch file (*.bat) and execute it:

CD "C:\Users\%USERNAME%\AppData\Local\Temp\Mindscape\WebWorkbench\Ruby193\Ruby193\bin"
gem update sass

by majnu | May 29 2014

Great tool with a few little quirks. I use it for sass in VS 2013 and it integrates really well into my work.

by rg777 | April 28 2014

by geezer498 | March 19 2014

This is a good extension but once my sass files get a little more complicated I have to wait 3 seconds or more between typing characters. It is unusable when this happens. I would give this extension 5 stars but the fact that I can't even type my sass out without waiting a million years makes it incredibly frustrating to use.

by KingOfHypocrites | March 07 2014

Docking some spammy tab in my IDE... Fail! Un-installed.

by Monstrik | March 02 2014

free version is poor functional that notepad

by alfanumeriek | February 28 2014

The "free" version cannot even compile LESS. It can just edit the file. So can notepad. Please dont fool me.

by Claire Botman | February 10 2014

by Tim Acheson | January 30 2014

by kieranjohn | January 27 2014

installed free version 3.2.1144.23109 on vs-2012
scss compile on save gives a blank css file
scss file only contains: html{visibility: hidden;}

by Dino Wang | December 30 2013

If you love SCSS too. This is the must have tool in Visual Studio.

by torerikk | December 12 2013

Large and heavy tool, that isn't really free.

by Jeff Mounce | December 06 2013

Still won't allow you to work with config.rb

by J.Verdurmen | November 23 2013

Large downloads, no working autocomplete and format document. I know you need the pro, but the free edition is just poor.

by Roman Hnatiuk -gm | August 22 2013

Good idea, but kind of useless with broken CoffeeScript debugger. Seems to be low priority project for Mindscape - they do not react to feedback, and release cycle seems to be rather slow.

Mindscape Limited August 25 2013
| Edit |
Delete

Hi Roman,

Thanks for the feedback. We don't provide a CoffeeScript debugger so I'm not sure how it's broken?

Certainly not a low priority product for us. We just can't please everyone as you'll note in April all the comments where that we were releasing too many updates too fast, so we did slow down based on that feedback (not on adding features, we just hold them longer before shipping them to the gallery. Pro users can get nightly updates with new builds if they wish to live on the bleeding edge).

I hope that helps explain the rationale and thanks for your feedback!

by MaksimVi | August 01 2013

Not really free, intellisense for SASS doesn't work in free edition (no autocomplete, no formatting or indentation). Forces you to upgrade to the paid version with modal pop ups and permanently docked controls.

by Adomorn | July 30 2013

intellisense is really poor when i am working on scss file. And if you are using web essentials bundle feature for css you have to save scss file before debug. thats why i gave 3 stars

by Diego Rio | April 22 2013

The product is quite good, but the too frequent updates with no perceived new features/bugfixes bothers their users.

Mindscape Limited April 23 2013
| Edit |
Delete

Hi Diego,

Sorry about the frequent updates recently. We integrated a crash reporter and have fixed a bunch of issues (many are fairly weird Visual Studio internal issues we're working around that we can't easily explain beyond 'stability improvements').

We'll be slowing down the update cycle as we have had a few people raise issues with this!

I hope that helps & thanks so much for your feedback!

by daysleeper55 | April 16 2013

I like this a lot. But must we have so many updates? Updates are good, but how about once a month or the occasional patch release

Mindscape Limited April 23 2013
| Edit |
Delete

Hi,

Sorry about the frequent updates recently. We integrated a crash reporter and have fixed a bunch of issues (many are fairly weird Visual Studio internal issues we're working around that we can't easily explain beyond 'stability improvements').

I'm glad you're not a user who has experienced some of the issues though! We are slowing down the update cycle as we've squashed all the issues that were reported.

Back to new feature development! :-)

I hope that helps & thanks so much for your feedback!

1 - 20 of 76 Items   
Sign in to start a discussion


  • Version 3.2.400.21116 | Less syntax messed up
    3 Posts | Last post August 16, 2012
    • Hi,
      
      I came back from a 2 week holiday last monday and say an update for the Web Workbench, so I installed it.
      But now stuff started happening which is really annoying me:
      - Syntax highlighting for nested rules is messed up: http://kipusoep.nl/1.png
          The first line with a { } is wrong, the second line is good
      - Syntax highlighting for variables is broken: http://kipusoep.nl/2.png (first line)
      - Less comments breaks the syntax highlighting for the rest of the page: http://kipusoep.nl/2.png (lines 3 - 5)
      - Pressing the enter key in various situations leads to unwanted behavior
          - Look at the cursor in this screenshot: http://kipusoep.nl/2.png
              When I press the enter key on that spot, this happens: http://kipusoep.nl/3.png
          - Take a look at these screenshots: http://kipusoep.nl/4.png
              The first arrow arrows means 'Pressing the enter key'. The second arrow means 'Pressing the } key followed by the enter key'. It's just completely confused it seems.
    • Hi Kipus0ep,
      
      Thanks for the feedback -- I'll just note that Jeremy will be helping you over on our forum (we get better notifications there so usually use that). Quickly though, we can't reproduce this behaviour so Jeremy will probably need to get some additional information from you.
    • Problem solved: http://www.mindscapehq.com/forums/thread/385341#385689
  • VS 2010 Mindscape Web Workbench Intellisense and Highlighting
    1 Posts | Last post May 31, 2012
    • Since I was running into problems with the intellisense and highlighting for .less files.  I uninstalled Chirpy.  I had Workbench installed prior to installing Chirpy, but after I uninstalled it, all intellisense and highlighting for it stopped working.  I checked and Chirpy was completely gone from my machine.  It was removed from the "Add-Ins" folder in both VS2010 and VS2008.  And sometimes the highlighting comes back intermittently, but is gone the next time I open VS.  Any help would be apprieciated.
      
      Thanks.
      
  • It's installed but where are the files??
    3 Posts | Last post March 15, 2012
    • I have it installed, open a new web project, right click add file-> nothing. None of the file types are available for creation. I am on VS2010 and I see the MindScape extension listed under installed extensions. I've tried this twice, what could I be doing wrong?
    • I'm having the same problem...
    • Hi,
      
      This was likely because there was no templates for Web Site projects. This should now be fixed in the new version we just deployed - can you please grab the update and see if it works? If it doesn't you can create a normal .txt file and rename it to a .less file in the meantime.
      
      I hope that helps!
  • Twitter bootstrap 2.0.4
    2 Posts | Last post March 15, 2012
    • Hello,
      
      I use you tool mainly with twitter bootstrap but the latest less files are written in less 1.3 and they give errors. Will there be an update so the less files will work when written in less 1.3 style.
      
      Greetings
    • The latest build now supports less 1.3 - check for updates now :-)
  • Twitter bootstrap 2.0.2
    2 Posts | Last post March 15, 2012
    • Hello,
      
      I use you tool mainly with twitter bootstrap but the latest less files are written in less 1.3 and they give errors. Will there be an update so the less files will work when written in less 1.3 style.
      
      Greetings
    • The latest build now supports less 1.3 - check for updates now :-)
  • Sass Partials not working
    2 Posts | Last post March 08, 2012
    • Hi, I love this plugin. Thank you.
      
      However I have a bunch of sass libraries (eg mixins) that i partial import into my main sass file. According to sass documentation for partial imports (Read link below under heading "Partials") naming a file beginning with an underscore eg _mixins.scss should NOT generate a .css file. It seems your plugin does not conform to this rule and for me is problematic. Any chance of a fix?
      
      http://sass-lang.com/docs/yardoc/file.SASS_REFERENCE.html#import
      
       
    • Hi Byron,
      
      Thanks for drawing this to our attention. It's not in the latest build but we'll add the ability to default to not generating the output for partials in a future release. At the moment, go to the 'Mindscape' menu item and go into the 'Web Workbench Options' and turn off 'compile' for the partials you have in your solution.
      
      Thanks again for the pointer!
  • min file generation
    3 Posts | Last post February 15, 2012
    • Is there a way to disable generating .min.css files (for scss)?
    • Not at the moment however we will investigate making this an option in the next 2 weeks for you.
      
      Thanks for the feedback!
    • Hello Marek, Support for this has been included in the latest release, please try it out!
  • Is there a way to compile and minify multiple .css and .less files into one?
    2 Posts | Last post February 08, 2012
    • I have various style sheets I would like to minify and combine into one, either on build or on save. Does the Pro version support this? If so, I'm buying. :)
    • Hi ElmerX,
      
      At the moment there is no way to do this, however we're just finishing off a fairly major re-architecture that should allow us to this type of thing (previously we used a SingleFileGenerator which, as the name suggests, runs per file and didn't give us the scope to do cool multi-file operations easily). Initial goal is feature parity so those current users get a seamless change. Following that we'll be adding all sorts of cool features like this to now that our underlying architecture can support it. We'll have the re-architected version out in the next week or so for testing and then within a couple of weeks following that I'd hope we can support your scenario. I'll post an update here once we support this.
      
      Thanks for the feedback!
  • Disable .less compilation
    2 Posts | Last post December 19, 2011
    • I'm using the web workbench mostly for .less syntax highlighting.
      The .less to css generating process is done by another tool I'm using called SquishIt.
      Since your last update I noticed web workbench is also creating a <name>.css1.css file (if the .less file is called <name>.css.less), with the following content:
      /* Less compilation is not available in the free edition of Web Workbench.  Visit http://www.mindscapehq.com/products/web-workbench to learn more */
      Problem is; these files will also get deployed to our servers, which really is unnecessary and it's messing up our projects.
      Is it possible to turn this 'feature' off? For me it's really annoying enough to stop using the web workbench tool... :-(
    • Hi,
      
      This should be resolved in the latest build however if the .less file was made PRIOR to the latest build it will still be an issue. You can remove the "CustomTool" property value in the properties pane for the .less file. Then delete the .less.css file that is generated and it should not be re-generated on save going forward.  I hope that helps.
  • Templates and compiling not working
    2 Posts | Last post November 14, 2011
    • Hey guys, I just installed on VS Ultimate 2010 and the templates doesn't appear on the list to add new files. Also, the css files for sass aren't being compiled :/
    • Hi Saulo,
      
      Does this forum discussion help with what might be going wrong? http://www.mindscapehq.com/forums/thread/4839 If it doesn't, please post on there and we'll help you out :-)
11 - 20 of 26 Items