WCF 3.5 Claims-aware Template

Free

Windows Identity Foundation SDK 3.5 Claims-aware WCF Service Web Site for Visual Studio 2010

(3) Review
Visual Studio
2010
Download (6,395)
2/27/2012
1.0
E-mail Twitter del.icio.us Digg Facebook
Add to favorites
Description
Reviews (3)
Q and A (1)
Sign in to write a review
Sort by:

by TheHendersonian | May 07 2014

Responding [very late] to Alnoor's issue...

The template not working is a bug in VS2010. To overcome it, try the following;

1. Find the template .zip archive, csClaimsAwareASPNETSite.zip in;

%USERPROFILE%\AppData\Local\Microsoft\VisualStudio\10.0\Extensions\Microsoft\ASP.Net 3.5 Claims-aware Template\1.0\ProjectTemplates

2. Extract the file ClaimsAwareASPNETSite.webproj

3. Using something like Notepad++, remove the NUL character at the end of the ClaimsAwareASPNETSite.webproj file.

4. Replace the ClaimsAwareASPNETSite.webproj file in the zip with the newly updated version.

From there, you should be good to go...

by Akram Alhinnawi | April 08 2013

Great Templates, I just wish there are something exactly the same for WIF 4.5.
All in all, amazing job, I even could install them manually for VS 2012 Ultimate but still though they work for WIF 3.5, Microsoft.IdentityModel not System.IdentityModel...

by alnoor | September 24 2012

Cannot install in VS 2010 SP1. I always get the following error:

---------------------------
Microsoft Visual Studio
---------------------------
Exception from HRESULT: 0x80041FEB
---------------------------
OK
---------------------------

I have installed all listed pre-requisites:
- WIF Runtime
- WIF 3.5 SDK

Sign in to start a discussion


  • Installation
    2 Posts | Last post September 24, 2012
    • Any times on installing?
      
      Cannot install in VS 2010 SP1. I always get the following error:
      
      ---------------------------
      Microsoft Visual Studio
      ---------------------------
      Exception from HRESULT: 0x80041FEB
      ---------------------------
      OK 
      ---------------------------
      
      I have installed all listed pre-requisites:
      - WIF Runtime
      - WIF 3.5 SDK
      
    • Errr... any *tips* on installing?
      
      
      Cannot install in VS 2010 SP1. I always get the following error:
      
      ---------------------------
      Microsoft Visual Studio
      ---------------------------
      Exception from HRESULT: 0x80041FEB
      ---------------------------
      OK 
      ---------------------------
      
      I have installed all listed pre-requisites:
      - WIF Runtime
      - WIF 3.5 SDK