SlowCheetah - XML Transforms

Free

This package enables you to transform your app.config or any other XML file based on the build configuration. It also adds additional tooling to help you create XML transforms.. Written by: Sayed Ibrahim Hashimi, Chuck England and Bill Hiebert

(103) Review
Visual Studio
2013, 2012, 2010
Download (135,662)
10/20/2013
2.5.10
View
E-mail Twitter del.icio.us Digg Facebook
Add to favorites
Description
Reviews (103)
Q and A (224)
Sign in to write a review
Sort by:

by CloudKarthik | Tue 8:54 AM

SlowCheetah doesn't work with Windows azure Web/worker Role projects.

by maskey | April 17 2014

by Mathias Colpaert | April 01 2014

SlowCheetah might be a bit buggy to set up, but once it works its great!

by Micky D | March 28 2014

Conflicts with ReSharper 8.1. Had to Suspend and Resume Resharper because I could not edit any file after applying a template

by Craig Brett (JP) | March 25 2014

I spent an afternoon trying to get this going for a team project. After a fair while thrashing with the already-mentioned "The SlowCheetah.Xdt.TransformXml" task could not be loaded from the assembly" problem, I eventually solved it by deleting the %localappdata%\Microsoft\MsBuild\Slowcheetah folder and it semed to resolve itself on my local machine and I was allowed to build and run stuff. I then deployed this to my colleagues who didn't have the plugin, under the impression that the NuGet package would make everything alright. No joy, regardless of what I tried. I'm now having to see if I can hand-roll a solution for changing config settings for people. Gets 2 stars because I like the idea and it kind of worked on my machine.

by Daniel Castenholz | February 07 2014

Nice integration with VS. Makes a chore much more manageable.

by Spesimensen | January 30 2014

Excelent tool! Thank you very much.

by Leonidas1 | December 06 2013

by AranV | November 27 2013

by 2Toad | November 23 2013

An invaluable addition to Visual Studio! Totally beats editing project files by hand. Well done!

by schleeke | November 11 2013

by Eric A. Duesing | November 01 2013

by Christoffer Johnsson | November 01 2013

Very nice tool, keep up the good work.

FYI to all people that get's build errors and use Ncrunch. You must include the package in Ncrunch, else you will get build errors.

http://tech.pro/blog/1586/making-ncrunch-build-projects-that-use-slowcheetah

Version 2.5.10.1 works well with ncrunch, version 2.5.10.2 and 2.5.10.3 doesn't.

by ankgupta067 | November 01 2013

facing error -
Error 1 The "SlowCheetah.Xdt.TransformXml" task could not be loaded from the assembly C:\Users\SESA254846\AppData\Local\Microsoft\MSBuild\SlowCheetah\v2.5.10\SlowCheetah.Xdt.dll. Could not load file or assembly 'file:///C:\Users\SESA254846\AppData\Local\Microsoft\MSBuild\SlowCheetah\v2.5.10\SlowCheetah.Xdt.dll' or one of its dependencies. The system cannot find the file specified. Confirm that the <UsingTask> declaration is correct, that the assembly and all its dependencies are available, and that the task contains a public class that implements Microsoft.Build.Framework.ITask. ConsoleApplication2

by WorkAByte | October 22 2013

amazing, cant believe I haven't found this sooner!
thanks for the simply awesome plug in

by MToons | October 08 2013

Excellent work -- so far only one major problem with web applications (solved here: http://stackoverflow.com/questions/16225304/using-slowcheetah-config-transforms-on-web-config-in-a-3-5-web-forms-app)

by e.sabbadin | September 19 2013

It works in vsnet 2012, but NOT on the TFS build server. I did not installed the plugin on the built server
I expected that the plugin was required only in the configuration phase, not to trigger the magic
, that is that it used the native xmltrasform features .. isn0t it the case ?

Sayed-Ibrahim-Hashimi September 21 2013
| Edit |
Delete

Hi e.sabbadin, when you install SlowCheetah into a project there is a message in the package manager console regarding build server support. Because of the way NuGet package restore is implemented there is some additional steps that need to be taken. You can read more info on how to enable that at http://sedodream.com/2012/12/24/SlowCheetahBuildServerSupportUpdated.aspx.

by Ed Schimmel | September 13 2013

It really annoys me that after an upgrade Slow Cheetah suddenly stopped working. In the first instance I was really pleased with this tool, but I can not use it when it is this buggy. It is a shame that there are no other tools doing the transformations, as far as I know.

Sayed-Ibrahim-Hashimi September 14 2013
| Edit |
Delete

Did you file a question in Q&A regarding your issue?

FYI please don't expect each release to be bug free. This is a one man project so I rely on the community to help in reporting issues when they arise.

by Mohammad Azis Fatoni | September 13 2013

by Pbsharper | September 06 2013

Highly recommended!
Used it for polyglot (f# c#) project. Worked without a hitch!

1 - 20 of 103 Items   
Sign in to start a discussion


  • I'm Stumped
    1 Posts | Last post December 27, 2012
    • My environment is VS 2010 Ultimate. I have a web app with 2 xml files - web.config and a metadata file for use with Indentity Framework. I have 3 build configurations set up.
      
      FYI - I took the lazt way out on the transforms. Rather than including only the deltas in the transform file, I am doing a complete REPLACE action in the first node of the files.
      
      I set up the web.config for Transform first, populated the transform files. The transform for the web.config works.
      
      The metadata file is a different story. Right after the Add Transform step I knew something was up. This is the first line of the original file before the Add Transform:
      <EntityDescriptor ID="_86192c4f-2aaa-43de-aec5-705f61278051" entityID="http://localhost/myapp/" xmlns="urn:oasis:names:tc:SAML:2.0:metadata"></EntityDescriptor>
      
      
      Here's the first line of one of the transform files right after the Add Transform:
      <EntityDescriptor xmlns:xdt="http://schemas.microsoft.com/XML-Document-Transform" xmlns="urn:oasis:names:tc:SAML:2.0:metadata"></EntityDescriptor>
      
      
      As you can see several attributes are missing. I can add those back and everything is good. However, in this transform file the REPLACE action needs to be on the EntityDescriptor line. If I add the REPLACE transform action:
      <EntityDescriptor xmlns:xdt="http://schemas.microsoft.com/XML-Document-Transform" xdt:Transform="Replace" ID="_86192c4f-2aaa-43de-aec5-705f61278051" entityID="http://localhost/SavaSecurity/" xmlns="urn:oasis:names:tc:SAML:2.0:metadata"></EntityDescriptor>
      and try to preview it I get an error dialog "There was an error processing the transformation". 
      
      Not sure where to go from here. Am wondering whether the additional attributes on that line are causing a problem.
      
      Your help will be appreciated......
  • Blank rows inserted into transformed configs
    1 Posts | Last post December 20, 2012
    • Hello
      I am using visual studio 2012 for a web-project and have tried slow cheeta to transform the different enviroment configurations. It works fine, but the estethics of the config-files are changed, like this:
      Before (XML is split onto rows for readability in our configs)-
      <site description="Example Site" siteId="some ID" licenseFilePath="drive\License.config">
            <siteSettings enableScheduler="true" stringCompressionThreshold="0"
              stringDelayedLoadThreshold="0" remoteWebServiceCulture="0" indexingDelayAfterPublish="00:00:20"...
      
      After transform (extra blank rows are inserted into the config):
      <site description="Example Site (new)" siteId="some other ID" licenseFilePath="drive\License.config">
          
        <siteSettings enableScheduler="true" stringCompressionThreshold="0" stringDelayedLoadThreshold="0" remoteWebServiceCulture="0"
          
        
        indexingDelayAfterPublish="00:00:20"...
      
      The configs still work since they are XML and have to "loose" value tags, but they look like crap and are hard to read if someone has to use notepad on a deploy server.
      
      I am unsure if this is an issue with slow cheeta or vs 2012 in general. Anyone got a pointer what I might have done wrong or where I can look for a workaround if this is an issue with slow cheeta or VS 2012?
      /Torbjörn
  • How to configure SlowCheetah to use Beyond Compare ?
    1 Posts | Last post December 07, 2012
    • Hello,
      
      I don't succeed to configure SlowCheetah in the Visaul Studio 2010 options, to use Beyond Compare as Diff tool.
      
      Could you give me the good settings please ?
      
      Thank you.
  • Can SlowCheetah be used to transform config files with reference to external config file (where config sections have configSource attribute set)?
    1 Posts | Last post December 06, 2012
    • I have a web.config file which refers a bunch of external config files using configSource attribute on the configuration elements. I would like to know if there is a way to transform this web.config file using either "web transformations" or "slow cheetah" or any other method, so that each of the environments (Staging/QA/UAT) will pick up a different external config files ?
      
      web.config :- 
      ==========
      
      =============================================================================
      .
      .
      .
      <connectionStrings configSource="Configuration\ConnectionStrings.config">
      </connectionStrings>
      .
      .
      .
      ==============================================================================
      
      ConnectionStrings.config :-
      ========================
      
      ==============================================================================
      <connectionStrings>
        <add name="DBCon1" connectionString="...." providerName="System.Data.SqlClient" />
        <add name="DBCon2" connectionString="...." providerName="System.Data.EntityClient" />
      </connectionStrings>
      ==============================================================================
      
      ConnectionStrings.Release.config :-
      =================================
      
      ==========================================================================
      <connectionStrings>
        <add name="DBCon1" connectionString="foo" providerName="System.Data.SqlClient" />
        <add name="DBCon2" connectionString="bar" providerName="System.Data.EntityClient" />
      </connectionStrings>
      ==========================================================================
      
      I want to know if there is a way to make the Web.config to point to Release.config file when the Release Configuration build is triggered from VS ?
      
      
      Thanks in advance.
  • can't get to install on VS2012
    2 Posts | Last post December 03, 2012
    • Hey guys.  I've installed this tool at my last 2 jobs in VS2010, however, I can't seem to get it working with VS2012.  IS there something different that needs to be done, or something I can check to make sure it installs correctly?
      
      If I try to reinstall, it tells me that it has been installed for all applicable products
    • Hi Kevin, it should be working fine for VS2012. Could you try and create a Win Forms project and right click on app.config to see if an Add Transform menu item appears or not?
  • publish fails after upgrade to 2.5
    5 Posts | Last post November 29, 2012
    • I just upgraded to 2.5, and now my publish fails with following error. Publish was working before upgrade.
      
      AppData\Local\Microsoft\MSBuild\SlowCheetah\v1\SlowCheetah.Transforms.targets(170,11): Error MSB4057: The target "CoreCopyTransformFilesWap" does not exist in the project.
    • There may be a bug here, see my comment at <a href="https://github.com/sayedihashimi/slow-cheetah/issues/52">https://github.com/sayedihashimi/slow-cheetah/issues/52</a> for a method to revert back to the previous version until I can fix it.
    • I have just updated the released version, this should now be fixed can you try it out and let me know?
    • Yet, it is working now. FYI, It did not work with direct update. I had to uninstall extension first and delete the SlowCheetah folder from AppData\Microsoft\MsBuild.
      
      Thank you!
    • That shouldn't be the case, I'll keep an eye out for feedback on this.
  • Anyone using this with unit tests
    2 Posts | Last post November 29, 2012
    • I have a unit test assembly that has a app.config, which has multiple configurations config files setup.  I've installed SlowCheetah 2.5.1.  When I compile and run the unit test assembly, the dll gets copied to the appropriate bin folder but the transform has not been performed on the app.config file.   Is there anything I can check to see if I've done something wrong?
      
      I am running the unit tests locally, there is no CI process involved at this stage.
      
      When I use VS2012 and preview the Transforms they all look good and work as expected.
      Thanks,
      Jason
    • Could you give specific steps that I could follow to reproduce your issue?
  • Changing formatting
    4 Posts | Last post November 24, 2012
    • I have the following XML in my transform file, and when it replaces the defined setting, the closing "</value>" tag is wrapped down to the next line and my setting value has a "\r\n   " tacked on the end of the email address.  Any idea what is causing that?
      
        <applicationSettings>
          <MyProject.Properties.Settings>
            <setting name="FinanceEmailAddress" serializeAs="String" xdt:Locator="Match(name)" xdt:Transform="Replace">
              <value>mary.jo@mycompany.com</value>
            </setting>
          </MyProject.Properties.Settings>
        </applicationSettings>
      
    • Hi, would you mind sending me your config file as well as the transform file? My email is (sayedha[at]{Mic​rosoft}[DOTCOM]).
    • Sorry to post on an old thread, but I'm having the same issue.
      Is there any solution available?
    • If you are still seeing this behavior there is no work around. Sorry.
  • Latest Update does not transform files
    5 Posts | Last post November 24, 2012
    • I've updated to the latest (2.5) and now all config files except for web.config do not transform on a publish using VS2012. My publish profile name is the same as the transform file suffix (Publish1 and myconfig.Publish1.config). The transform preview works correctly. The previous version was working fine with the publish profiles I created. The published config files are not modified in any way (they still retain the original last modified date). I also used the vsix from issue 46 and the transform did not occur.
    • Can you give specific steps? I just tried the following and it worked.
      
      1. Create a new project
      2. Add transform details to web.debug.config/web.release.config
      3. Add foo.xml
      4. Add Transform on foo.xml
      5. Add transform details to foo.debug.config/foo.release.config
      6. Publish to an Azure Web Site using MSDeploy
      
      From what I can see it looks like its working
    • Doing some troubleshooting it looks like the problem is limited to file system publishing to a directory. Changing the publish to a web deploy or web deploy package runs the transforms.
    • File System publish for web only supports extensibility from the command line. When publishing from VS the same extensibility doesn't exist in the UI. So there is nothing SlowCheetah can do here. For this the best thing to do is open a bug at connect.microsoft.com. 
    • Ignore my previous comment, its not 100% correct.
      
      Can you try it out with the latest version and let me know if it doesn't work for you?
  • Cannot see the "Add Transform" context menu item
    2 Posts | Last post November 22, 2012
    • Hello Internets,
      
      I am unable to get the "Add Transform" context menu item to appear for existing and new test projects, and am hoping someone out there has experienced a similar issue.
      
      I'm running Visual Studio 2010 on Windows 7, and have the latest version of NuGet (2.1.31002.9028) installed (I install SlowCheetah via Solutions Explorer>Manage NuGet Packages).
      
      I've tried starting VS as follows:
      1) "devenv.exe /log" but that did not produce helpful info. 
      2) "devenv.exe /SafeMode" but experienced the same problem
      3) As an administrator
      
      
    • What do you mean by "test project"? When you create the project what is the title of the project in the Add New Project dialog?
91 - 100 of 224 Items