SlowCheetah - XML Transforms


This package enables you to transform your app.config or any other XML file based on the build configuration. It also adds additional tooling to help you create XML transforms.. Written by: Sayed Ibrahim Hashimi, Chuck England and Bill Hiebert

(101) Review
Visual Studio
2013, 2012, 2010
Download (134,348)
E-mail Twitter Digg Facebook
Add to favorites
Reviews (101)
Q and A (222)
Sign in to write a review
Sort by:

by Mathias Colpaert | April 01 2014

SlowCheetah might be a bit buggy to set up, but once it works its great!

by Micky D | March 28 2014

Conflicts with ReSharper 8.1. Had to Suspend and Resume Resharper because I could not edit any file after applying a template

by Craig Brett (JP) | March 25 2014

I spent an afternoon trying to get this going for a team project. After a fair while thrashing with the already-mentioned "The SlowCheetah.Xdt.TransformXml" task could not be loaded from the assembly" problem, I eventually solved it by deleting the %localappdata%\Microsoft\MsBuild\Slowcheetah folder and it semed to resolve itself on my local machine and I was allowed to build and run stuff. I then deployed this to my colleagues who didn't have the plugin, under the impression that the NuGet package would make everything alright. No joy, regardless of what I tried. I'm now having to see if I can hand-roll a solution for changing config settings for people. Gets 2 stars because I like the idea and it kind of worked on my machine.

by Daniel Castenholz | February 07 2014

Nice integration with VS. Makes a chore much more manageable.

by Spesimensen | January 30 2014

Excelent tool! Thank you very much.

by Leonidas1 | December 06 2013

by AranV | November 27 2013

by 2Toad | November 23 2013

An invaluable addition to Visual Studio! Totally beats editing project files by hand. Well done!

by schleeke | November 11 2013

by Eric A. Duesing | November 01 2013

by Christoffer Johnsson | November 01 2013

Very nice tool, keep up the good work.

FYI to all people that get's build errors and use Ncrunch. You must include the package in Ncrunch, else you will get build errors.

Version works well with ncrunch, version and doesn't.

by ankgupta067 | November 01 2013

facing error -
Error 1 The "SlowCheetah.Xdt.TransformXml" task could not be loaded from the assembly C:\Users\SESA254846\AppData\Local\Microsoft\MSBuild\SlowCheetah\v2.5.10\SlowCheetah.Xdt.dll. Could not load file or assembly 'file:///C:\Users\SESA254846\AppData\Local\Microsoft\MSBuild\SlowCheetah\v2.5.10\SlowCheetah.Xdt.dll' or one of its dependencies. The system cannot find the file specified. Confirm that the <UsingTask> declaration is correct, that the assembly and all its dependencies are available, and that the task contains a public class that implements Microsoft.Build.Framework.ITask. ConsoleApplication2

by WorkAByte | October 22 2013

amazing, cant believe I haven't found this sooner!
thanks for the simply awesome plug in

by MToons | October 08 2013

Excellent work -- so far only one major problem with web applications (solved here:

by e.sabbadin | September 19 2013

It works in vsnet 2012, but NOT on the TFS build server. I did not installed the plugin on the built server
I expected that the plugin was required only in the configuration phase, not to trigger the magic
, that is that it used the native xmltrasform features .. isn0t it the case ?

Sayed-Ibrahim-Hashimi September 21 2013
| Edit |

Hi e.sabbadin, when you install SlowCheetah into a project there is a message in the package manager console regarding build server support. Because of the way NuGet package restore is implemented there is some additional steps that need to be taken. You can read more info on how to enable that at

by Ed Schimmel | September 13 2013

It really annoys me that after an upgrade Slow Cheetah suddenly stopped working. In the first instance I was really pleased with this tool, but I can not use it when it is this buggy. It is a shame that there are no other tools doing the transformations, as far as I know.

Sayed-Ibrahim-Hashimi September 14 2013
| Edit |

Did you file a question in Q&A regarding your issue?

FYI please don't expect each release to be bug free. This is a one man project so I rely on the community to help in reporting issues when they arise.

by Mohammad Azis Fatoni | September 13 2013

by Pbsharper | September 06 2013

Highly recommended!
Used it for polyglot (f# c#) project. Worked without a hitch!

by zendu | September 06 2013

Release simply sucks. It cannot even build project by throwing error - Could not copy the file"...exe.config" because it was not found.

PS: I wonder why there is no way to download earlier versions. It would at least made it easy to downgrade. With corporate firewall blocking NuGet packages, I am left with no options but to uninstall SlowCheetah and wait for next release that will fix the issue. So bad!

Sayed-Ibrahim-Hashimi September 14 2013
| Edit |

Sorry I had some issues with Things should be better with 2.5.8, can you try and let me know? FYI regarding installing older versions you can always use the NuGet package manager console to install a specific version of the build support.

by Rihan Meij | August 21 2013

One of my essential tools for creating automated builds.
Thanks for making this so easy.

1 - 20 of 101 Items   
Sign in to start a discussion

  • Unit testing with MSTest
    2 Posts | Last post February 17, 2013
    • Hi,
      I was wondering if anyone has managed to get this working with MSTest and deploying item.
      I have a BBCSearch.config file that has transforms for the different Environments. This file get transformed and outputted to the correct directory when build.
      I can not find away to deploy the TRANSFORMED file to the test directory 
      When i add it as a deployment items as <projectpath>\BBCSearch.config, the original file is copied not the TRANSFORMED file.
      Any ideas?
    • Sorry I do not have much knowledge in this area, perhaps someone else in the community may be able to help out.
  • Missing Build Configuration Transform Files
    4 Posts | Last post February 07, 2013
    • We have a solution with 8 different build configurations. When I right-click on an app.config file in one of the projects and choose "Add Transform", only app.Debug.config and app.Release.config transform files are created. In other solutions, SlowCheetah works as expected. Anyone have any idea what's going on? Here's a list of the build configurations we have:
      Debug (with DB Deploy)
      Could the problem be based on one of the build configuration names? Thanks in advance. Using VS 2010 with SlowCheetah 2.5.1.
    • I'm having the same issue on VS2012.  Did you figure it out?
    • The issues is likely how you have created your build configurations. In VS when you create a build configuration it asks if you want to create a Project Configuration as well. You should check that checkbox. With SlowCheetah the transforms are based on Project Configurations, not solution config.
    • Just solved this, which is somewhat embarrassing, but the issue is that the individual project doesn't have all the configurations that the solution does.  Manually adding the new configurations should fix the issue.
  • ClickOnce not working
    3 Posts | Last post February 06, 2013
    • I just installed version 2.5.2.  I'm trying to publish a WPF application for ClickOnce.  I just started up a blank WPF project, added a transform to the App.config, and published.  When I install the application, the config file isn't there.  Can anybody else confirm?  I'm using Visual Studio 2012 Ultimate.
      What I do see is that an App.config.deploy file gets created in the publish\Application Files\WpfApplication1_1_0_0_0\obj\Debug\SlowCheetah directory when I publish.  When the application is installed, an App.config file gets created using that same folder structure, but there's no WindowsApplication1.exe.config file created where the application needs it.
    • Hi Frank, sorry about that. I just posted a new version it should resolve this issue. Can you update and try again?
    • That fixed it.  Thanks a lot for your quick response.
  • How to Transform Value inside Colletion
    1 Posts | Last post January 31, 2013
    • I have a collection of nodes, in a particular node i want to find a node and replace its values. This is custom section
          <Type name="t1">
              <subType name="t1s1">
              <subType name="t1s2">
              <subType name="t1s3">
           <Type name="t2">
              <subType name="t2s1">
              <subType name="t2s2">
              <subType name="t3s3">
      How would i replace the Value in Type="t1" , subType ="t1s2" ?
      Also how can i write a sysntax, that if node is present replace it otyherwise insert it?
  • Packaging an Azure app.. no transform
    8 Posts | Last post January 29, 2013
    • I have a Worker Role project with an app.config.  I have 6 different configurations with transforms in them.
      When packaging an Azure app for deployment (right-click the "Cloud" project and select "Package"), the worker role's configuration files do not get transformed, or at least packaged up properly.
      Is there a way to make this happen?
    • I have same problem Tom. Did you find a solution?
      Can anyone help please?
    • Hello Tom,
      I found this version working:
      Please download the new version pointed in this comment.
      Gautam Jain
    • Thanks for sharing the link. If there are any further comments regarding this feature its best to keep those on the issue page <a href=""></a>
    • Would I have to uninstall and reinstall it?
    • I am having the same issue.  Your comments look hopeful.  However, I can't seem to get to the link provided by by gautambjain.  Is the link correct?  Does it reference a version other than what is currently on the web site?  Do I need any permissions to get into ?
      Please advise.  Thanks.
    • I have an update.  I did find the 2.5.1 release in the drop box.  I uninstalled the prior release, and installed 2.5.1 on an existing project.  Unfortunately, it doesn't seem to do the transform when I create a new package for an existing worker role.  I am trying to transform app.config (which transforms as desired/expected when I go into debug). Is there anything else I need to do after the install besides re-generate the Azure worker role package?
      Note I am using the November 2011 Azure SDK.  Are the transforms dependent on the June 2012 Azure SDK release?
    • Chuck, you will need the latest Azure SDK. I have not tested the support with prior versions.
  • XML-Transformation error when build deployment package
    2 Posts | Last post January 25, 2013
    • Hello,
      The XML-translation works very well in Visual Studio for my web project, but when I build a deployment package, I get a web.config with one error : only one XML-transformation doesn't done. I have $(ReplacableToken_xxx)" instead of :
          <add name="MyConnectionString"
               connectionString="$(ReplacableToken_MyConnectionString-Web.config Connection String_0)"
      Here is my xml-transformation :
              <add connectionString="Data Source=MyDB\BE,1433; Initial Catalog=MyDB;Integrated Security=SSPI" xdt:Transform="SetAttributes(connectionString)" xdt:Locator="Condition(@name='MyConnectionString')"/>
      Thank you for your help.
    • Thanks for the feedback this is not related to SlowCheetah. This is a part of the Web Project publish/package support. I've blogged more details of this at
  • Build not transforming on TFS Build Server
    7 Posts | Last post January 14, 2013
    • When I build a package on my local machine it transforms just fine, all transforms are good.  But when I submit the job to the build server it doesn't work.  I get multiple versions of the configs and they are not transformed.  I've followed the instructions and included the dll and targets file in TFS, and even embeded it in my web project.  I've pointed the project file to where the target file is: <SlowCheetahTargets Condition=" '$(SlowCheetahTargets)'=='' ">$(MSBuildProjectDirectory)\App_Data\SlowCheetah.Transforms.targets</SlowCheetahTargets>
      But I still seem to be using the transform file in my %appdata% directory - when I rename it I can't even preview the transform.  Shouldn't it use the one defined in the project file and in TFS instead?  If I am still using the .target in appdata then the build server is too...
        Using TFS 2010, VS 2010, my build is building configurations "Any CPU|Ext.Prod", same as my workstation.  I have nothing in my Build events.
       Any ideas?
    • The only info I have regarding this is my blog post at <a href=""></a>. If you are still having issues try to see if a community member can help out.
    • I have the same issue. I've already set up my project exactly as laid out in the post by Sayed, but the build server still does not transform my config files. Using the local publishing from Visual Studio works fine, though. 
    • If you take a look at the build log you should see if the .targets file is getting imported or not. I am guessing that the file is not being imported. Could you take a look and let me know if you are able to determine that?
    • You are right. The .targets file is not even being referenced. My path to the targets file was not correct. Anyway, once I've got that fixed, I found one more issue. When I access the source files in my TFS Build server (_PublishedWebsites\ProjectName), the config files are NOT transformed. However, they are transformed within the packages (_PublishedWebsites\ProjectName_Package). Is there any way to correct this? 
    • I am having the same problem. What can I expect to see in the log file if the SlowCheetah targets file is being imported?
    •   So, apparently my transforms may have been working the whole time on the build server.  I was looking at the configs in the _PublishedWebsites build directory, seeing that they were not transformed.  It didn't occur to me that the zipped package might contain different configuration values than the unzipped directory! (Thanks deweaver!)
        Also, my server build log does not contain references to ".targets" or "SlowCheetah" anywhere.
        Everyone needs to check the config files deep inside of the zipped Project_Package file to tell if the transform worked on the build server.
        I will now re-assess our use of this tool (I had given up on it).  Certainly fixing it to do the transforms in both build directories would make it much more useful.
  • I'm Stumped
    1 Posts | Last post December 27, 2012
    • My environment is VS 2010 Ultimate. I have a web app with 2 xml files - web.config and a metadata file for use with Indentity Framework. I have 3 build configurations set up.
      FYI - I took the lazt way out on the transforms. Rather than including only the deltas in the transform file, I am doing a complete REPLACE action in the first node of the files.
      I set up the web.config for Transform first, populated the transform files. The transform for the web.config works.
      The metadata file is a different story. Right after the Add Transform step I knew something was up. This is the first line of the original file before the Add Transform:
      <EntityDescriptor ID="_86192c4f-2aaa-43de-aec5-705f61278051" entityID="http://localhost/myapp/" xmlns="urn:oasis:names:tc:SAML:2.0:metadata"></EntityDescriptor>
      Here's the first line of one of the transform files right after the Add Transform:
      <EntityDescriptor xmlns:xdt="" xmlns="urn:oasis:names:tc:SAML:2.0:metadata"></EntityDescriptor>
      As you can see several attributes are missing. I can add those back and everything is good. However, in this transform file the REPLACE action needs to be on the EntityDescriptor line. If I add the REPLACE transform action:
      <EntityDescriptor xmlns:xdt="" xdt:Transform="Replace" ID="_86192c4f-2aaa-43de-aec5-705f61278051" entityID="http://localhost/SavaSecurity/" xmlns="urn:oasis:names:tc:SAML:2.0:metadata"></EntityDescriptor>
      and try to preview it I get an error dialog "There was an error processing the transformation". 
      Not sure where to go from here. Am wondering whether the additional attributes on that line are causing a problem.
      Your help will be appreciated......
  • Blank rows inserted into transformed configs
    1 Posts | Last post December 20, 2012
    • Hello
      I am using visual studio 2012 for a web-project and have tried slow cheeta to transform the different enviroment configurations. It works fine, but the estethics of the config-files are changed, like this:
      Before (XML is split onto rows for readability in our configs)-
      <site description="Example Site" siteId="some ID" licenseFilePath="drive\License.config">
            <siteSettings enableScheduler="true" stringCompressionThreshold="0"
              stringDelayedLoadThreshold="0" remoteWebServiceCulture="0" indexingDelayAfterPublish="00:00:20"...
      After transform (extra blank rows are inserted into the config):
      <site description="Example Site (new)" siteId="some other ID" licenseFilePath="drive\License.config">
        <siteSettings enableScheduler="true" stringCompressionThreshold="0" stringDelayedLoadThreshold="0" remoteWebServiceCulture="0"
      The configs still work since they are XML and have to "loose" value tags, but they look like crap and are hard to read if someone has to use notepad on a deploy server.
      I am unsure if this is an issue with slow cheeta or vs 2012 in general. Anyone got a pointer what I might have done wrong or where I can look for a workaround if this is an issue with slow cheeta or VS 2012?
  • How to configure SlowCheetah to use Beyond Compare ?
    1 Posts | Last post December 07, 2012
    • Hello,
      I don't succeed to configure SlowCheetah in the Visaul Studio 2010 options, to use Beyond Compare as Diff tool.
      Could you give me the good settings please ?
      Thank you.
81 - 90 of 222 Items