Quick Add Reference

Free

Add missing assembly references right from the code editor

(20) Review
Visual Studio
2010
Download (22,598)
7/15/2013
1.0.10
View
E-mail Twitter del.icio.us Digg Facebook
Add to favorites
Description
Reviews (20)
Q and A (20)
Sign in to write a review
Sort by:

by Sinae | November 20 2013

doesn't work in 2013

by Robert Sundstrom | April 30 2012

by IAManushin | November 14 2011

by SkipIsHere | November 01 2011

A great extension, it's one of the many I can't live without, now if only Microsoft would add this in as a core feature of VS....

by GCATNM | August 22 2011

Very cool! This is something I think you actually don't need all that often, but everytime you do, you ask yourself "Why the hell doesn't VS offer me to add that reference when it has already figured out which one I need ?!"

by Muse Extensions | July 20 2011

Fantastic extension

by Robert MacLean | March 24 2011

by Ace.Ventura | February 28 2011

Very useful extension 5 stars, but the UPDATE POPUP is really annoying (-3 stars), once time, I couldn't close it and had to kill VS process.

by J. Lucas | December 12 2010

by Daniel Schaffer | November 01 2010

Excellent plugin, but I just got bombarded by a barrage of VS popups to update this plugin, which basically made my instance of VS unusable. I had to shut it down using task manager. NOT COOL.

by AndyMauer | October 17 2010

by Brooke Hamilton - MSFT | October 15 2010

This just saved me a few frustrating minutes. Thanks!

by Clarius Consulting | October 08 2010

Guys, please let's use the "Q and A" section to post your support questions, so we can follow up, etc.

@Jontatas: it will be very weird that Quick Add Ref is causing this as it is just an editor extension although I don't know what the Oracle extensions are about. Are the public and available to download so we can try to repro? URL to the version you're using?

@guaike: sorry we haven't done any testing on non-english VS. are you getting an error? any stackcall you can share? or it just doesn't work? you can reach us with more info at wovs@clariusconsulting.net

by guaike | October 08 2010

It does't wrok for me,
My VS2010 is Chinese Version.

by Jontatas | October 07 2010

It's not working for me. When VS 2010 loads it gives an error saying:
The 'Oracle Developer Tools for Visual Studio .Net' package did not load correctly.

The problem may have been caused bu a configuration change or by the installation of another extension.

So I guess it's a no-go to use this if one want's to use the Oracle dev tools.

/J

by to-rparker | October 07 2010

by sudheerkovalam | October 07 2010

Amazing... Very very useful Addin.
This should have been in VS by default!

by spano | October 06 2010

by Will Sullivan | October 06 2010

So simple, so brilliant.

by Scott Dorman | October 06 2010

Definately a "must have".

Sign in to start a discussion


  • The bits have expired
    2 Posts | Last post June 29, 2012
    • Hi, when starting VS with the latest version of this extension installed (v0.9.8), we are getting the message: "The bits have expired, please download an updated version from the Extension Manager dialog (Tools -> Extension Manager)."
      
      But there are no updates for this extension showing in the update screen. Also the installed version is v0.9.8 and the latest version on this page is also 0.9.8.
      
    • Hi stratnl, sorry about the inconvenience. We hit an issue uploading the latest version but it is now up. Please update to version 0.9.9 and it should work. Thanks for reporting this.
  • Not working
    5 Posts | Last post May 10, 2012
    • I installed this extension to VS2010 Ultimate. I can see it installed in the Extension Manager also but it does not work. 
      If I type .Net framework class name whose reference I have not added explicitly, it does not show the DLL which contains the class definition when I hit Ctrl "period" on the classname.
      
      I have restarted VS 2010 multiple times and also uninstalled/installed this extension twice, but no success.
      
      Any help will be greatly appreciated.
      
      Thank you.
    • Just want to clarify that my VS2010 is in English language only.
    • Does this happen with only one type? Or is it not working at all with any types you try? Can you let us know which is the full class name of the type you describe above? Thanks.
    • This happens with all types. I tried creating objects of variety of classes like WebMethod, WebHttpRequest,  Choices. Each one of them is in a different DLL whose reference was not added to the project. The popup that appears on Ctrl-Period did not show any options except "Generate class for...."
    • I think I believe was happening. This extension comes built-in with a small cache for some common types. And the way it works is it "learns" about new types/DLL once you have added the assembly reference to your project by hand at least once. Can you please try adding by hand the DLL containing the type in question then work some time with it (the extension will add on the background the types of that DLL to its own type cache), then create/open a new solution where that DLL is not there and try Ctrl+. with a typename in that DLL? Thanks.
  • WoVS Quick Add Reference unable to use in non-English Visual Studio 2010
    6 Posts | Last post November 09, 2011
    • I found that this extension unable to use in non-English Visual Studio 2010.  When I switch to English locale, then this extension become available.  Is this a bug?
    • FYI.
      
      How I switch to English language is using:
      
      1. Tools menu > Options > Environment > International Settings
      2. Choose Language to "English"
      
      There is only "English" can show up "WoVS Quick Add Reference" options.
    • I only have a German Versin and no chance to switch to the english language. Any chance to publish a non-language-depended version ?
    • Hi guys, our current test scope only covers the English language, sorry. I'll log a bug into our database for the team to take a look at what may be causing it to stop working on non-english versions, although I can't really promise this will get fixed... Thanks for reporting it.
    • Hi Guys,
      
      nothings new anbout this problem ?
    • Hi knarf,
      
      We don't have the resources right now to properly develop and test this extension against non-english languages... we know this pretty much sucks if you're not using english... sorry about that.
      
      Thanks
  • Digital signature mismatch
    4 Posts | Last post November 04, 2011
    • Apparently this is the same problem as with the last update for the default browser switcher extension. When I'm trying to update to 0.9.4 I receive a "digital signature mismatch" error and the update is not installed.
    • Hi Peter, soon after posting the update we uploaded the signed bits. Can you try it now and let me know please? Thanks.
    • Hi again. Thank you for the quick reply - yes, I just tried to update again and it worked.
    • Glad to hear that!
  • New Build 0.9.3 available!
    1 Posts | Last post October 01, 2011
    • Including an extended beta expiration date and minor fixes. Please update ASAP! 
  • Not working for me
    3 Posts | Last post September 01, 2011
    • I'm with VS 2010 Premium. In Extension manager I can see extension is installed fine.
      Anyway entries it should create as smart tags or context menu in Error list are simply missing.
      Any ideas what can be wrong?
    • Hi Delcho, can you let us know what type name are you typing and into what type of project (C# console, winform, etc?) Thanks.
    • Hi,
        It's C# console application - I pasted the sample code from here: http://msdn.microsoft.com/en-us/library/bb286958.aspx
        First type VS complains about is TfsConfigurationServer, but the only entries displayed via 'ctrl-.' are 'Generate class..' and 'Generate new type'.
        In the example there's list of the 2 references that are needed, but I decided to just test the extension.
  • New 0.9.2 build available!!
    1 Posts | Last post August 31, 2011
    • Includes minor bug fixes and an extended beta expiration date. Please update ASAP!. Thanks.
  • Update warning spam
    9 Posts | Last post July 04, 2011
    • I just got bombarded by an unending series of modal dialog boxes informing me that the "bits have expired" and that I needed to update from the web site. I'm assuming that this was just some logic gone awry, but I have serious objections against interrupting someone's work flow for a software update. The update should show itself *ONCE*, when VS first starts, and then not ever again, at least for the rest of the VS session.
      
      As to what actually happened, I had to shut down VS using task manager because the popups wouldn't stop coming. Not cool.
    • Also, would be nice to have a direct link to the place I need to download from, rather than an unclickable url to the www.wovs.com home page.
    • Hi Daniel,
      
      Sorry for the inconvenience -- this was obviously a bug in our side in the expiration detection logic that made the popup message keep coming (other extensions don't have this bug and the message is shown only once). Of course you didn't have to know this, but if you just move the caret/mouse away from the smarttag the popup should go away and give you a chance to go to the Extension Manager to update the extension instead of having to kill the VS instance.
      
      We've also now updated the message which wasn't correct, the bits need to be downloaded from the VSGallery either by hand or by using Extension Manager.
      
      Please make sure you're now running the 0.4 version which was this ugly issue fixed.
      
      Apologies again for the glitch,
      
      thanks
      
      
    • I've just encounter the same pop-up attack problem. I uninstalled the current version 
    • and installed the latest version (0.6) via Extension Manager and restarted VS. Unfortunately, it did not stop the pop-ups. In the meantime I'm disabling the extension as a workaround.
    • Unfortunately I've just the same problem with a recently downloaded (0.6) version.
      Moving the caret away from the current position stopped the bombardment of message boxes. Annoyingly this happened part way through typing "bool", and I'm not that slow at typing.
    • Yep, the issue is still happening with the latest version.  Not only that, if you open a solution from the command line, the dialog won't even show, and VS essentially locks up (while being responsive) during the phase where the "preparing solution" VS dialog is showing.  
      
      The WOVS extensions should update themselves like everything else.  They should continue to work, and a new update should show up in the extension manager when available.  
    • This worked fine for a couple of months and then the popup started. I uninstalled the extension and then downloaded the latest version from here and via the Extension Manager UI. In both cases I get an error: 
      ---------------------------
      Microsoft Visual Studio
      ---------------------------
      The extension could not be installed because the following error occurred:
      
      
      
      The file is not a valid VSIX package.
      ---------------------------
      OK   
      ---------------------------
      
    • Hi amiller5000, the error you're mentioning is usually caused by a corrupted file, looks like your download may have been corrupted. We've also seen that sometimes firewalls can get in the middle, thinking the .vsix may have a virus and deleting its files which then causes VS to fail. You may want to try to download the .vsix file manually from the VS Gallery, copy it to your desktop, unzip the file with any zipping program (just rename .vsix to .zip before doing so) and check that the files are there. Then give it a try manually by double cliking on the .vsix file saved to your desktop. Thanks.
  • Slow reloading solutions
    1 Posts | Last post November 24, 2010
    • Since installing this extension, I've noticed all solutions I open after the first are significantly slower to load.  For example, we have a 50+ project solution that will take <5 seconds to load the first time I open it on a fresh instance of Visual Studio; if I do nothing more than close the solution and open it up again, the solution takes >20 seconds to load.  We also have a larger solution (150 projects) that goes from 10-15 seconds on a fresh instance to 3+ minutes the next time it's opened.  
      
      I've narrowed the issue down by disabling each extension in Visual Studio - as long as this extension is disabled, Visual Studio loads solutions fast each and every time.
  • Doesn't Work On Static Class Member References
    2 Posts | Last post October 18, 2010
    • Take the following two lines (ignore that the first one is stupid, it is to show my example only):
      
      ConfigurationManager cm;
      
      string s = ConfigurationManager.AppSettings["s"];
      
      Both instances of ConfigurationManager refer to the same class, however only the first one receives the "Add Reference System.Configuration, 4.0.0.0" popup.  This may be something that is not fixable as the second ConfigurationManager does not even get a "Generate Class/Generate New Type" dropdown upon pressing Ctrl+. (the built in VS2010 feature).  Possibly I should report this to Microsoft -- What do you think?
    • Hi Travis,
      
      Sorry for the late reply. As you correctly point out, for static classes, the C# language is not offering the smart tag thus we don't get a chance to show our stuff in there.
      You may want to post the issue in MS Connect and to check with the C# team if this is either a bug or "by design".
      
      thanks
11 - 20 of 20 Items