Web Essentials 2012

Free

Adds many useful features to Visual Studio for web developers.

(192) Review
Visual Studio
2012
Download (1,088,633)
9/10/2014
3.8
View
E-mail Twitter del.icio.us Digg Facebook
Add to favorites
Description
Reviews (192)
Q and A (324)
Sign in to write a review
Sort by:

by Ammar.Zaied | February 13 2015

nice !

by Gene Kohli | January 21 2015

Sweet Suite!

by Bob Blork | May 30 2014

nice!

by Shreeharsh Ambli | April 17 2014

brings in new capabilities

by Ilya Galakhov | February 19 2014

Thank You!

by Jitbit1 | February 04 2014

No more LESS support in the latest version. But "LESS" is there on the product page, there's even a LESS-settings tab in the options. Thanks for ruining our work process.

This extension is #1 result in Google for "Visual Studio LESS".

PS. the new "ASP.NET and Web Tools 2012.2" only highlights LESS code, but does not compile it!! So your answer does not help!!

by Proco | January 27 2014

Amazing extension!

by Richard D | December 19 2013

Nice tools, but unfortunately Typescript is left out of the recent update. So a lot of the functionality I used is not available anymore.

:-(

by harwi | November 30 2013

Great tool!

by Breno Queiroz | November 27 2013

You Must Have It!

by Balaji M Kundalam | November 23 2013

Useful add on.

by GK Dev | November 20 2013

by TW Scannell | November 19 2013

This says is updated today.It fails to install in VS 2012 Express

Mads Kristensen November 20 2013
| Edit |
Delete

Unfortunately, VS Express doesn't support 3rd party extension. It's not a limitation of Web Essentials

by Eliezer Perlmutter | November 01 2013

by Leonardo Lourenço Silva | November 01 2013

Very USeful !!!

by Christiaan Rakowski | October 28 2013

by HiTech Magic | October 22 2013

Dropping support for TypeScript (without plastering that "little" detail all over the download page) has just cost me 4 wasted hours and sent me full circle back to the old Web Essentials.

1. Installed Web essential update
- lost TypeScript support

2. Installed separate TypeScript add-in from MS
- Does not build existing TypeScript files in project

3. Researched how to modify project to get it to build TypeScript files
- Still does not build existing TypeScript files in project

4. Created a new project minimal testbed to test TypeScript compiling
- ts files are added, with TypeScriptCompile option, but do not generate .js files at all. Tools | Options etc have no effect

5. Researched this new problem
- Gave up in disgust

6. Uninstalled TypeScript & latest Web Essentials

7. Installed old Web Essentials
- Luckily this was still in my download folder

8. Have now lost color-coding, intellisense and all those other features that made Web Essentials useful.
- Decide to write grumpy review :(

I have never had so much grief from one update. In future I will Google for problems with the updates before even thinking about pressing upgrade!

by Cattousa | October 15 2013

WebEssentials 2012 is a stellar extension. Being able to collapse JavaScript between {curly brackets} is very useful.

by Ytrog | October 15 2013

Good plugin although the CoffeeScript functionality doesn't compile the scripts and crashes vs2012 every time I try :(

by Aleksandar Totovic | October 08 2013

It's very nice

1 - 20 of 192 Items   
Sign in to start a discussion


  • Build | Web Essentials | Update All Bundles
    6 Posts | Last post December 03, 2013
    • When I select Build | Web Essentials | Update All Bundles I receive an error:
      The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))
      
      I just updated to version 3.3.5 today.  Prior to this, the bundles were not updating when a source file changed.  They are still not updating and I receive the above error.
      
      Thanks...
    • same error here :(
    • I receive the same issue, updating a file does not update the bundled files. This seems to get worse after install update 4 for VS2012. Also, selecting Update All Bundles generates the same error referenced by @jdubsmith
    • Where can I find older versions of Web Essentials? It seems like people are down grading to v3.2 to fix the JS bundling issue. 
    • See:
      
      https://github.com/madskristensen/WebEssentials2012/issues/19
      
      for more details. Downgrading to v3.2 fixes the issue for me as well.
      
    • older versions here, must guess the version number :)
      http://vswebessentials.com/nightly/webessentials2012-2.9.vsix
  • JS bundles broken in 3.3
    5 Posts | Last post December 03, 2013
    • JS bundles seem to be broken in 3.3. Once I downgraded to 3.2, they started working again.
    • Yeh, same problem here!
    • same
    • +1
    • same here. 3.3.5 broke the bundle updates. going to 3.2.0 seems to solve the issue.
  • JavaScript XMLDoc comment scaffolding Stopped Working
    1 Posts | Last post December 02, 2013
    • JavaScript XMLDoc comment scaffolding has stopped working for me
      I am using VS 2012 and WE 2012 v3.3.5
      I installed visual studio update 4 to see if that would fix it but no luck
      I also tried VS 2013 with WE 2013 but it doesnt work there either
  • no automatic minification in typescript project
    2 Posts | Last post November 30, 2013
    • It's a great tool, however the current version (3.3.5 with VS2012 update 4 and typescript 0.9.1.1 ) does not created minified js automatically in typescript projects.
      I have tried many previous versions of webessentials back to 2.9 and different ways of including the ts and js files into the project, either as DependentUpon liek this
      
      <TypeScriptCompile Include="app.ts" />
      <Content Include="Scripts\app.js">
            <DependentUpon>app.ts</DependentUpon>
      </Content>
      
      or as included on the folder level.
      <TypeScriptCompile Include="app.ts" />
      <Content Include="app.js" />
      
      When typescript compiles the ts to js, webessentials does not trigger the minification; when I then open the js file and save it manually at some point webesssentials might build the min.js version (eratic as far as I can see), but this will also add the new file to the project tree, from then on webessentials will not update the min.js again. Doing a project rebuild will not automatically minify.
      
      
      I can reproduce this with the standard typescipt project template.
      
      
      
      
      
    • I just realized, that when manually saving the js file, webessentials will (!) create/update the minified version. But this does not happen when the typscript compiler updates the js file. 
      This makes it necessary to go manually through all your compiled js files and save them before publishing a release (bundled) project. 
      Also the js files are not by default included in the typescript project so one first has to include these js files to be able to create the minified versions.
  • LESS minification to css and min.css not working in 1.3.1
    1 Posts | Last post November 27, 2013
    • I cannot get a LESS file to minify to .css (and .min.css) in Visual Studio 2013 Premium. I'm using Web Essentials 1.3.1. This was working fine in Visual Studio 2012? Is this a bug? (Note: When I right-click a less file, I see a "Minify CSS file(s)" option, but it's grayed out.)
  • circular compiling
    2 Posts | Last post November 20, 2013
    • Having saved ONE FILE (inside of .bundle) WebEssentials saves/updates all other bundles.
      
      The log:
      11/20/2013 4:23:46 PM: Updating bundle: 1.js
      11/20/2013 4:23:47 PM: Updating bundle: 2.js
      
      <here pops an error window about script not found, starting with "/">
      
      11/20/2013 4:23:52 PM: Updating bundle: 1.css
      11/20/2013 4:24:16 PM: Updating bundle: 1.js
      11/20/2013 4:24:20 PM: Updating bundle: 1.css
      
      If one have over 9000 bundles it will crash everything. Is there a setting to update only *currently* saved bundle-file?
      
      Could be "/" at the beginning of the path related (version 1.3.1 16.11.2013)
    • Sorry ignore, that concerns VS2013
  • Coffee Compiler Not Up To Date
    3 Posts | Last post November 19, 2013
    • It seems as if the version of the coffee compiler included with Essentials is not current. I notice this because up until now we've been using node.js to compile our files. The compiled output of WE seems to include more "safe" local variables and extra spaces you saw from previous coffee versions.
      
      We'd really like to start using WE for compilation but we have a number of users who will still be using node.js on their Macs to compile files. We don't want to have them constantly switching back and forth. Would it be possible to update the version of the included coffee compiler? Better yet, would it be possible to make the compile command an option? This would allow us to specify compilation with node and worry about the coffee version on our own.
      
      
    • We're slowly moving over to use NodeJS for compiling LESS and CoffeeScript, but only in WE 2013. Right now, only LESS uses NodeJS for compiling, but we're moving CoffeeScript to nodejs soon as well
    • Thanks for the update. Is it possible we can manually update the coffee.js file in our local installations?
  • LESS Not Generating CSS
    9 Posts | Last post November 19, 2013
    • After updating to 2.9, changes to the LESS file are NOT updating the corresponding .css nor the .min.css files.  This is a critical bug and needs to be fixed quick please.
    • I forgot to ask, where can I get version 2.7?  That one worked and right now I'm in the tank with 2.9.
    • I wanted to report that this is still broken in 3.0.  Also, if anyone else needs 2.7, I finally found a link to it, so here you go:
      
      http://vswebessentials.com/nightly/webessentials2012-2.7.vsix
    • It works for me with VS2012 Ultimate with update 3 and v3.0 of web essentials. Initially, it looked like VS wasn't even recognizing the .less file, however, on closing and reopening the file, I got the split view and the generation of the .css and .min.css files also started working. 
    • This is still broken with v3. The LESS "Compile on build" does not work. And does not compile all the less files, still only does the current one I am viewing.
    • This isn't working on my machine either. I have Visual Studio 2012 Ultimate. When will this be fixed? This is the main reason I'm using this plugin (which is very helpful btw). -Chris
    • I just confirmed WHY this is not working.  This is also broken with Web Essentials 2013.  Our LESS files use the import to import general configuration styles, e.g.,
      @import-once "styles.variables.less";
      
      And then use them later, e.g.,
      
      .group-label {
         .mix-label-group;
         clear: both;
      }
      
      I commented out all the .mix... imported/pre-configured styles and the CSS file was then updated upon saving the LESS file.  Once I re-enabled the .mix... styles, then it hosed again.
      
      Please fix this ASAP as it's a huge hassle.  Thanks a lot.
    • I reported it as a bug in the bug system here:
      https://github.com/madskristensen/WebEssentials2013/issues/233
      
      Hopefully it'll get fixed soon in both WE 2012 and 2013.
    • Okay, found more info on this and it looks like it's NOT a WE 2012 or 2013 bug but a change in LESS starting with 1.4.0.  Here's the blurb from the 1.4.0 release notes found at http://lesscss.org/#changes
      
      @import-once is removed and is now default behaviour for @import.
  • Bug in version 3.2
    3 Posts | Last post November 06, 2013
    • The following is showing up in the Output, after the final results line (i.e. "========== Rebuild All: 2 succeeded, 0 failed, 0 skipped ==========") when building (Rebuild or Build):
      
      10/21/2013 03:52:37 PM: The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))
         at EnvDTE.Properties.Item(Object index)
         at MadsKristensen.EditorExtensions.ProjectHelpers.GetRootFolder()
         at EnvDTE.Properties.Item(Object index)
         at MadsKristensen.EditorExtensions.ProjectHelpers.GetRootFolder()
      
    • This doesn't look right:
      
      if (dte.Solution.Projects.Count == 1 && !string.IsNullOrEmpty(dte.Solution.Projects.Item(1).FullName))
      {
          return dte.Solution.Projects.Item(1).Properties.Item("FullPath").Value.ToString();
      }
      
      Should it be:
      
      if (dte.Solution.Projects.Count == 1 && !string.IsNullOrEmpty(dte.Solution.Projects.Item(0).FullName))
      {
          return dte.Solution.Projects.Item(0).Properties.Item("FullPath").Value.ToString();
      }
      
    • I appear to be getting one exception for each C/C++ project (managed or not) in the solution.  This happens in both the VS 2012 and VS 2013 versions.
  • vs2012 crashes with Compile on Build
    1 Posts | Last post November 01, 2013
    • When I turn on Compile on Build my new install of vs2012 and fresh install of Web Essentials crashes my dev environment.  I tried reinstalling Web Essentials.
      
      Here's the error in my app log if that helps
      
      Application: devenv.exe
      Framework Version: v4.0.30319
      Description: The process was terminated due to an unhandled exception.
      Exception Info: System.IO.FileNotFoundException
      Stack:
         at System.IO.__Error.WinIOError(Int32, System.String)
         at System.IO.FileStream.Init(System.String, System.IO.FileMode, System.IO.FileAccess, Int32, Boolean, System.IO.FileShare, Int32, System.IO.FileOptions, SECURITY_ATTRIBUTES, System.String, Boolean, Boolean, Boolean)
         at System.IO.FileStream..ctor(System.String, System.IO.FileMode, System.IO.FileAccess, System.IO.FileShare, Int32, System.IO.FileOptions, System.String, Boolean, Boolean, Boolean)
         at System.IO.StreamReader..ctor(System.String, System.Text.Encoding, Boolean, Int32, Boolean)
         at System.IO.File.InternalReadAllText(System.String, System.Text.Encoding, Boolean)
         at System.IO.File.ReadAllText(System.String)
         at MadsKristensen.EditorExtensions.LessProjectCompiler.MinifyFile(System.String, System.String)
         at MadsKristensen.EditorExtensions.LessProjectCompiler.Completed(MadsKristensen.EditorExtensions.CompilerResult)
         at MadsKristensen.EditorExtensions.LessCompiler.ProcessExited(System.Object, System.EventArgs)
         at System.Diagnostics.Process.OnExited()
         at System.Diagnostics.Process.RaiseOnExited()
         at System.Diagnostics.Process.CompletionCallback(System.Object, Boolean)
         at System.Threading._ThreadPoolWaitOrTimerCallback.WaitOrTimerCallback_Context(System.Object, Boolean)
         at ...
21 - 30 of 324 Items