Your extension will be available shortly on the Visual Studio Marketplace at this link.

Web Essentials 2012


Adds many useful features to Visual Studio for web developers.

4.5 Star
Visual Studio
Download (1,159,345)
E-mail Twitter Digg Facebook
Add to favorites
Sign in to write a review
Sort by:

4 Star
by VB6 Programming | July 31 2016

Better than 2015 Web Essentials

5 Star
by coderbd | July 28 2016

As a front end developer. I'm very much exited about minification process of this.

4 Star
by Jony Green | September 06 2015

I'm not a developer, i always use free online js minifier( and css compressor(

5 Star
by Dan Randolph | May 01 2015

I love the css help.

3 Star
by Ammar.Zaied | February 13 2015

nice !

5 Star
by Gene Kohli | January 21 2015

Sweet Suite!

5 Star
by Bob Blork | May 30 2014


5 Star
by Shreeharsh Ambli | April 17 2014

brings in new capabilities

5 Star
by Ilya Galakhov | February 19 2014

Thank You!

1 Star
by Jitbit1 | February 04 2014

No more LESS support in the latest version. But "LESS" is there on the product page, there's even a LESS-settings tab in the options. Thanks for ruining our work process.

This extension is #1 result in Google for "Visual Studio LESS".

PS. the new "ASP.NET and Web Tools 2012.2" only highlights LESS code, but does not compile it!! So your answer does not help!!

5 Star
by Proco | January 27 2014

Amazing extension!

5 Star
by Richard D | December 19 2013

Nice tools, but unfortunately Typescript is left out of the recent update. So a lot of the functionality I used is not available anymore.


5 Star
by harwi | November 30 2013

Great tool!

5 Star
by Breno Queiroz | November 27 2013

You Must Have It!

5 Star
by Balaji M Kundalam | November 23 2013

Useful add on.

5 Star
by GK Dev | November 20 2013

3 Star
by TW Scannell | November 19 2013

This says is updated today.It fails to install in VS 2012 Express

Mads Kristensen November 20 2013
| Edit |

Unfortunately, VS Express doesn't support 3rd party extension. It's not a limitation of Web Essentials

5 Star
by Eliezer Perlmutter | November 01 2013

5 Star
by Leonardo Lourenço Silva | November 01 2013

Very USeful !!!

5 Star
by Christiaan Rakowski | October 28 2013

1 - 20 of 196 Items   
Sign in to start a discussion

  • "Sources" in .map files pointed to incorrect directory
    1 Posts | Last post June 17, 2013
    • The sources property in the generated .map file seems to always include the relative path from the root of the server.  The problem is that our applications use virtual directories and therefore these references don't work when trying to debug from the browser.  It all seems unnecessary too since the bundling is happening at a folder level so you could always assume the reference is relative to the map file.  We are having to add a post build step to fix our references in the "sources" property after each time Web Essentials messes them up.
      Other than that, great job ;) 
  • TS files are no more opened by Web Essentials
    2 Posts | Last post June 15, 2013
    • I've just noticed that in my sln tree the icons of .ts-files became 'media-playerish' (old-style 'film' icon with the 'play' sign on it), and the same time Web Essentials seems to know nothing of the .ts-files. Symptoms: 
      - ts-files are opened in VS by plain text editor; no intellisense, no generation on save; 
      - no generation on build if set;
      How to fix it? Reinstalling of WE didn't help. Nor did setting Windows file '.ts' association from Media Player to VS.
    • UPD: at the same time LESS is opened by WE Editor, everything works fine for less
  • @import file and image url
    1 Posts | Last post June 04, 2013
    • Hello,
      In my project I have the following directories :
      component.less contains the following style :
      background: url(../images/triangle_v3_top.png) no-repeat; 
      The component.less file is imported in core.less :
      @import "components\component.less";
      In the core.css file generated I have this :
      background: url(composants\../images/triangle_v3_bottom.png) no-repeat;
      The backgroug url is wrong, it must be :
      background: url(../images/triangle_v3_bottom.png) no-repeat;
      When I use Prepros to build less file ( the url is correct.
  • CSS Bundle doesn't update
    2 Posts | Last post May 28, 2013
    • I have a CSS bundle and no matter what I try, it won't update. When I make modifications to a .less file and save it, the corresponding .css file is updated. Then I try to build the website or I go the to Web Essentials menu under BUILD and select "update all bundles" but nothing happens.
    • I had a similar issue but with just the minified versions of the bundles. For me, if I removed one of the <file> entries from the .bundle file, saved, then added it again, the bundle would get updated properly. Hope it helps!
  • Web Essentials does not minify less
    1 Posts | Last post May 27, 2013
    • When i save my less files they do not get minifyed even if I have set it to create .min.css
      Output says : 
      LESS: Compiling _styles.less
      _styles.less compiled
      But no min.css or css either. What can be wrong here?
  • less compile on build option not working
    1 Posts | Last post May 24, 2013
    • I'm attempting to use the 'compile on build' option for less and it doesn't seem to be working.  (latest version, 2.7)  I change a dependent file, hit compile and the main less file that imports that file doesn't get rebuilt.  The only way I can get the main less file to regenerate the css is to go into it directly and hit save.  Am I doing something wrong?
  • @importing several files fails (thread bombs)
    2 Posts | Last post May 20, 2013
    • I have a couple of .less files that do no more than facilitate the inclusion of smaller less files -- such as a responsive grid LESS file that sets up media queries and then imports each break, in a total of 6 @import calls (one for grid setup, one for design, for Desktop | Mobile | Tablet). 
      When I try to save these files I notice a cscript.exe thread getting up to about 2GB of RAM and then breaking. Is there anyway I can debug this extension to give a better understanding of where this breaks? I get an empty error that simply states 'LESS: '
    • I'm a dummy. The issue I was having was from not using @import-once. I believe @import-once is removed in the latest version of LESS so that's probably why I decided to remove them from my code.
  • @import of files outside current project fails with 404
    12 Posts | Last post May 20, 2013
    • Hi!
      Just upgraded from 2.5.1 to 2.6, and all our cross-project imports stopped working. Like this:
      @import "../../../../Themes/MiP.Theme/Styles/mip-mixins.less";
      This worked before but now gives the following compiler error:
      LESS: Couldn't load themes/MiP.Theme/Styles/mip-mixins.less (404)
      Can you fix this please? :) Or tell us what we're doing wrong. Or provide some kind of workaround. We are not very keen on duplicating all our less files... :)
    • Has this been addressed, or is there a workaround?
    • Same problem here.
    • The interesting thing is that LESS is supposed to be handled by Web Tools now since 2.5. Reverting back to the 2.5.1 download from fixed my problem. I imagine both Web Tools and Web Essentials have some conflicting dependency for path resolution. 
    • Reverted to 2.5.1 also and all seems well... for now.  Just wish I knew if this is a bug in 2.6 or an intentional change.
    • I am seeing this issue in 2.6 inside of the same project - rolling back to 2.5.1 has not resolved the issue.  Think there may be a remnant lurking somewhere after the uninstall.
    • 3 cycles of uninstall and reinstall later - 2.5.1 now functioning as expected.
    • See this thread for the description of the issue and for a possible workaround:
    • Alternatively you can just downgrade the less compiler from v1.3.3 to v1.3.1 which fixes the issue. See here:
    • The "Replace with original 1.3.0" workaround here worked for me.
      It looks like the problem is really with Web Tools. I imagine that Web Tools or Web Essentials or both fiddles with the scripts in that directory so reveting to 2.5 reverts the 1.3.3 script to 1.3.0
    • This bug remains in Web Essentials 2.7 as the LESS version is still 1.3.3 and has not been reverted (though the script file name is less-1.3.0.js).
    • Reverting to v1.3.0 in Web Essentials 2.7 doesn't work for me. Instead, it just keeps creating threads that go to compile the LESS but just consume memory.
  • JSDoc and IntelliSense
    2 Posts | Last post May 19, 2013
    • Is there some magic setting to get JSDoc comments to be parsed for IntelliSense?  I can't seem to get this working in 1.7.  I have a simple test file with the following:
       * Does something.
       * @param {string} myParam
      function doSomething(myParam) {
      Inside the function, myParam seems to have no type information.  Outside, inline documentation just spits out the whole unformatted comment block for doSomething.  Anyone have any ideas how to get this to work?  Thanks!
    • I am having the exact same problem.  JSDOC does *NOT* work as described.  Am I missing something?  I am using the exact same format as dornif:
       * Does something.
       * @param {string} myParam
      function doSomething(myParam) {
      But when attempting to use 'doSomething', Intellisense just dumps out the entire comment block (/* ... */) above the function instead of providing the intellisense I expect for each parameter.
  • Compile Jade to Html
    1 Posts | Last post May 11, 2013
    • Jade is a really nice alternative to typing Html manually. The best Jade engine is in node, but to get to use it for non-node apps aswell using it as a pre-processor would be a nice alternative. WebStorm already does this 
81 - 90 of 328 Items