MSpec Test Adapter


Machine Specifications Visual Studio 2012, 2013 Test Adapter

(3) Review
Visual Studio
2013, 2012
Download (5,351)
E-mail Twitter Digg Facebook
Add to favorites
Reviews (3)
Q and A (7)
Sign in to write a review
Sort by:

by GSM007 | May 14 2014

A very helpful tool. This will save my time in selecting tests lying in single project. As of now no issues.

Thanks for sharing this tool.

by Adrian Arkady | February 16 2014

great tool for BDD with VS!

by mayvazyan | December 05 2012

Thank you! Works in Visual Studio and on build server as well!

Sign in to start a discussion

  • Add nuget package for test runner
    1 Posts | Last post June 05, 2015
    • It would be also useful adding nuget package for test runner. It is nice to have it automatically downloaded by the build server.
  • Error :Unknown Custom Metadata item Kind
    1 Posts | Last post May 13, 2015
    • I've a project where mspec tests are not loaded, and I can see in Tests output this error
      Machine Specifications Visual Studio Test Adapter - Error while discovering specifications in assembly C:\Develop\xxx\xxx\src\Collaboration\Collaboration.Engine.Tests\bin\Debug\Collaboration.Engine.Tests.dll - Unknown custom metadata item kind: 6
      The strange stuff is that everything worked, then stopped suddently giving this error.
  • Support for VS2015 RC
    3 Posts | Last post May 13, 2015
    • Could you please update the adapter to run with VS2015 now that it is in RC? I really love this adapter :) and I cannot work without it.
      Thanks a lot!!
    • Hi, I have recently handed this project over to a new owner as I don't have the time to do it justice. They have assured me they are working on this issue, you should see an update in the near future.
    • Actually I've verified that simply unzipping the adding and changing the manifest is enough to have it run under VS 2015 :)
  • TFS 2013 Test Case Filter
    1 Posts | Last post March 12, 2015
    • Is there a way to use the Test Case Filter in the TFS Build Definition to selectively run MSPEC test cases?
      If so, could someone provide the Test Case Filter syntax as well as a sample of decorated code?
  • Code coverage - false negative
    1 Posts | Last post February 27, 2015
    • Using the code coverage of the VS on my project, it tells me that I'm not having a 100% code coverage because there is one instruction that apparently is never hit.
      But if I put a breakpoint in that instruction and perform a test debug, the breakpoint is hit. What can be wrong?
  • No indication whether tests pass or fail
    2 Posts | Last post November 05, 2014
    • I have a very simple test and the UI does not indicate whether it failed or passed. Basically the UI does not update. I get this error after the test completes:
      Machine Specifications Visual Studio Test Adapter - Error while executing specifications in assembly ... - The process cannot access the file 'C:\Users\...\AppData\Local\Temp\d05645cd-e5c0-4c20-8033-f55de314011f\d05645cd-e5c0-4c20-8033-f55de314011f\assembly\dl3\789104d5\6adc2d7e_4ff5cf01' because it is being used by another process.
      Why is it looking for that path and how can I fix the issue?
    • So I looked more into this and seems like if I change the Thread.CurrentPrincipal then the runner does not update the UI. Right now I am saving the original principal and changing it back because the runner needs it.
      I hope that helps.
  • update please
    4 Posts | Last post March 27, 2014
    • this tool is awesome!
      could you make an update so that it fully works with latest version of MSpec and VS2013? I have an issue, that it doesn't display the MSpec Subject.
      Also, support for MSpec [Tags] would be great as VS traits.
    • I'll try get an update out soon, I've been working outside of the VS ecosystem lately so the test adapter hasn't got any recent love.Tag support is a great idea for traits.
    • Version 0.1.4 now fully supports the latest MSpec 0.7.0 and MSpec Tags can now be used as traits, I also added support for the newer style Custom Assert Delegate Attributes.
    • Nice tool.
      Not sure if this is the place for asking a question about a bug ... 
      Today I was running my tests and one of the tests was silently failing (test runner was not reporting it as either passed/failed).
      When I ran the tests using the mspec it error's saying that I have more than one because clause in my type hierarhcy (a valid error).
      But MSpec adapter did not display the error and was failing silently.
      You can simulate this using the code @