Your extension will be available shortly on the Visual Studio Marketplace at this link.

Visual Studio Achievements For VS2010

Microsoft Free

Bring some game to your code with Visual Studio Achievements!

3.9 Star
Visual Studio
Download (136,561)
E-mail Twitter Digg Facebook
Add to favorites
Sign in to write a review
Sort by:

4 Star
by Bruno Maestro | August 15 2015

Good incentive for developers to try new things

5 Star
by Ondřej | March 13 2015

Now I am focusing more on getting various achievements than on coding :(

4 Star
by chriga | May 22 2014

Coding with more fun..

1 Star
by Gontronix | September 13 2013

Crashes all the time after fresh install wih the same error people have posted multiple times already. Seems that some people found it fixed after installing the latest version of FXCop. As we are not using FXCop I can't try that. Can't use the achievement plug-in in 2010 for now which is a pity as I really liked the idea of it.

5 Star
by Sócrates Lopes | August 22 2013

Really cool extension! Makes me think much more about my code.

5 Star
by Sile Huang | July 31 2013

5 Star
by Ali.Alikhani | June 28 2013

1 Star
by Cieszak | June 27 2013

crashed in vs 2010

4 Star
by D. Chatterjee | May 20 2013

Same problem

1 Star
by svanleusden | March 26 2013

Installed -> restarted VS2010 -> opening VS2010 -> plugin crashed :-(

Any fix coming soon?

1 Star
by The Uncivil Engineer | January 28 2013

Installed, error on open, disabled.

1 Star
by PakoDev | January 09 2013

I keep getting an error message when loading visual studio. I had to uninstall it.

1 Star
by Gasner Software Inc_ | December 28 2012

Was awesome, until the last update when it decided to crap out.

1 Star
by krokador | December 18 2012

last update crashed the entire extension. I keep getting an error message when loading visual studio. Uninstalled. It coulda been fun, but it's not worth it.

5 Star
by Mads Kristensen | November 28 2012

5 Star
by Mario185 | November 19 2012


5 Star
by XMaverick | November 07 2012

It's really funny to have achievements while coding. I like really this extension, and I install it in every Visual Studio box I have.

5 Star
by Thiag0coelho | November 06 2012

Need more achievements indeed!
Quite good anyway

4 Star
by Evangi Studio | November 06 2012

Excellent, but "Show me the cache" doesn't want to work :)

Need more achievements!! :)

5 Star
by Exe.Cute | November 01 2012

fun stuff

1 - 20 of 120 Items   
Sign in to start a discussion

  • I'm gettnig a fatal error, which I think it related to VS Achievements
    1 Posts | Last post February 07, 2012
    • I'm trying to update a WPF app I wrote in VS 2010.  When attempting to run it in the debugger, Visual Studio suddenly closes.  No warnings, nothing.  I've posted a detailed message about this on MSDN Social forums.  Here's a link to it:
  • Not posting achievements
    2 Posts | Last post February 06, 2012
    • Hi,
      My achievements doesn't get posted, on the channel9 page. When I look up my user, it has 0 started and 0 completed, yet VS tells, when it starts, that I have completed various achievements.
      I have no funny characters in my username.
      I'm behind a proxy, is it possible that it blocks it somehow? I have no clue how it posts the results.
    • Just realized that there is a version 1.2, that should fix proxy issues :). I'll give that a try.
  • VS is busy.
    4 Posts | Last post February 05, 2012
    • I have the following problem:
      Every time I start VS2010, the "Install and register..." achievement is executed, but then, in a minute or two, VS hangs and shows a notification that it is executing some internal work and is busy.
      I think it happens because achievements add-in can't send a request to site which track achievements.
      If I disable this add-in, I can work normally.
      Windows 7 Pro x64,
      VS2010 Ultimate,
      Add-ins and extensions: ReSharper, vs10x CodeMap, AnkhSVN + CollabNet SVN Browser, Regex Editor, MySQL tools for database design.  
    • Updated Achievements to v1.1.
      Still the same problem - Visual Studio hangs up and shows a balloon that it's busy.
      Also, "Install and Register For Visual Studio Achievements" still is executed but not added to the achievements page.
      I just have to disable it again, 'cause I can't work when this extension is enabled - VS just hangs.
    • My guess is that you are getting hit by the proxy bug?
    • Same problem here. When the plugin is disable, VS works normally but when I enable it, VS goes in a busy state and stay in this state until I force close VS.
      I have only ReSharper as plugins.
  • Open Source?
    1 Posts | Last post February 03, 2012
    • It would be amazing to see what the community could do with an open version of this extension.
      Software development involves so many opinions and methodologies.  Why not build your product around a marketplace for achievement flavors?  For example, a "Mythical Man-Month" set, "Code Complete" set, and, more ridiculous, a "Programmer Ryan Gosling" set (rewards include pictures of him).
      I'd love to fork your code.
  • Error when opening Achievements menu
    1 Posts | Last post February 03, 2012
    • Just gave this a try on v1.2.
      I can login when I first launch VS after installing (it comes up with a prompt for my proxy credentials), but afterwards, none of the achievements register and opening the Tools -> Achievement view gives a "Cannot perform runtime binding on a null reference" error. My Token and User keys under HKCU\Software\Microsfot\VisualStudio\10.0\VSAchievements is filled.
  • it doesn't work on VS11
    4 Posts | Last post February 03, 2012
    • it shows "this extension is not installable on any currently installed produscts."
      Can I install it on VS2010 only?
    • Correct. VS2010 Professional, Premium and Ultimate.
    • Could you add support for VS11?
    • Seems odd for a VS2010 VSIX not to work in VS11... What would it take to correct? A recompile?
      <Todd />
  • InstallAndRegisterForAchievements wont show
    6 Posts | Last post February 02, 2012
    • The InstallAndRegisterForAchievements achievement won't register, although other achievements will! The other achievements show up as started, but won't show as completed - even if they are. My guess is that's because the InstallAndRegisterForAchievements is still showing 0.
      Here's my json link:
    • Just had a look in fiddler and it looks like the http post request to update the achievements is coming back with HTTP 400 Bad Request
    • I too get the HTTP/1.1 400 Bad Request reponse. I have tried this to get VS to use the default proxy, but it made no difference.
    • Also having issues with proxy (that requires a password). I can login when I first launch after VS (it comes up with a prompt for my proxy credentials), but afterwards, none of the achievements register and opening the Tools -> Achievement view gives a "Cannot perform runtime binding on a null reference" error. My Token and User keys under HKCU\Software\Microsfot\VisualStudio\10.0\VSAchievements is filled.
    • For me the achievements do not get updated, the http posts return with 400. Registry is correctly filled, no proxy.
    • Hoping that Version 1.2 should fix this experience. Give it a try and let us know if it works.
  • No achievements posting on Channel9, only one shows unlocked in VS, but reporting that I've earned 6
    2 Posts | Last post February 01, 2012
    • The Tools -> Achievements dialog only shows one achievement unlocked (Regional Manager), the Channel 9 site shows nothing earned, and I get several popups showing I've earned a lot of them, including registering for achievements... 
      Rather disappointing if you ask me... :-(
    • May something wrong with your network setting?
  • WARNING: Repeating Menu, Icon bug when using Achievements Extension
    2 Posts | Last post January 27, 2012
    • I love the plugin, but I did encounter a serious bug.  This morning, all of the menus, submenus and icons in the VS UI were repeated 4 times.  I tried many things... restarting, reseting the customizations, etc. and nothing work.  Finally, I disabled the Achievements Extension and everything went back to normal.
      Just something to watch out for...
    • Thanks for reporting; we have logged and are investigating.
  • Not working with SP1?
    10 Posts | Last post January 27, 2012
    • I have SP1 (10.0.40219.1 SP1Rel) and it doesn't appear to be working.  I don't get any achievements, although I should, and when I go to Tools -> Achievements I get an error "Cannot perform runtime binding on a null reference"
      Works fine on a computer without SP1.
    • Same for me.
    • Same happens for me. Shame :(
    • Me too...really disappointed.
    • I am currently using with Visual Studio 2010 Ultimate and SP1 with no problem.
    • I saw all these other posts with username problems, so out of curiosity I went to HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0\VSAchievements and saw that there was no value under "Token".
      So I went to Tools->Options->Visual Studio Achievements, hit "Change User", re-logged in, and everything works now.
    • I still had problems after that.  Opening up Fiddler I noticed a bunch of Achievement calls were caught by my proxy because Visual Studio isn't using the system proxy credentials.
      I followed this tutorial and everything works consistently now:
    • Another person with the same problem,  when I go to Tools -> Achievements I get an error "Cannot perform runtime binding on a null reference"
      However I do have an achievment and my achievment is reflected on site.   No Toast though! :(
      I have looked at my reg value for user and this is there,  however gameshints suggests going to options\visualstudio achievements\   I don't have this so can't..   
      Would be interested in the solution though,  looks like fun!.
    • In my case, I don't have underscore in my user name, but still getting the error.
      somehow system default proxy is not working. so I have to add my proxy manually.
      In devenv.exe.config, my configuration looks like this:
          <defaultProxy useDefaultCredentials="true" enabled="true">
            <proxy  proxyaddress="http://Proxy IP:port" />
            <servicePointManager expect100Continue="false" />
            <ipv6 enabled="true"/>
    • Thanks for this guys.  We are looking into how to fix this in the extension itself, but this seems like a good workaround in the meantime.
51 - 60 of 87 Items