Your extension will be available shortly on the Visual Studio Marketplace at this link.

Team Foundation Server Power Tools December 2011

Microsoft Free

Power Tools are a set of enhancements, tools and command-line utilities that increase productivity of Team Foundation Server scenarios.

4.1 Star
Visual Studio
Download (766,800)
E-mail Twitter Digg Facebook
Add to favorites
Sign in to write a review
Sort by:

2 Star
by dscse | September 16 2015

5 Star
by podpolanec | January 27 2015

Thanks for this useful tool.

5 Star
by DsantanaBR | May 20 2014


1 Star
by Ohad Redlich | May 19 2014

I downloaded and tried to install, but then I get: Error 1334. The file 'AlertsExplorer.mht' cannot be installed .....

Am I the only one ?

3 Star
by Bobby Barry | March 18 2014

I just want to see other people's reviews and it is forcing me to rate the product first! I've not used the tool.

5 Star
by DevDan2014 | February 17 2014

This solved my problem. If you are after enforcing code-commenting, then download and install this program.
Add the new "policy" that is now available in Source control and restart Visual Studio.
Users now have to enter comments.

1 Star
by Indu Venu711 | August 08 2013

I am trying to install this , but it always gives me an error "Error : 1001"

Can someone please help.

5 Star
by Ali.Alikhani | June 28 2013

2 Star
by Nagsen Meshram | June 05 2013

tfpt.exe workitem /update doesn't work. Anyone knows whom to contact?

4 Star
by Sergio Parra | April 27 2013

Great set of tools! It makes all easier!

3 Star
by BasantP | November 15 2012

This is nice tool and make TFS funtions easier..

5 Star
by BruceP | November 07 2012

5 Star
by Fabiano Batista | August 07 2012

I tested the backup tool feature, and it worked perfectly. Very handy tool.

1 Star
by 吴慧锋 | August 02 2012

dose not work in vs 2012 rc, work with vs 2010 but can not edit Microsoft Visual Studio Scrum 2.0 - Preview 4

5 Star
by GanganapalliPavanKumar | July 01 2012

It is very nice being able to edit XAML within the build process templates. This should be a common tool within Visual Studio. Thanks for doing this.

3 Star
by smartellie | June 20 2012

Don't know why I cannot view the 78 reviews that others have written. Microsoft - get with the "app" process - we all expect to see other reviews before we buy a product...

5 Star
by Gerald Bauer | June 15 2012

It is nice being able to edit XAML within the build process templates. This should be a common tool within Visual Studio. Thanks for doing this.

5 Star
by Mr. Wharty | June 08 2012

Another must have add-in

Great tools for TFS...

5 Star
by verma.nitin | May 17 2012

1 - 20 of 94 Items   
Sign in to start a discussion

  • Restore team project collections to an earlier point in time
    2 Posts | Last post January 17, 2012
    • When I use the "Restore Database" feature from the "Team Foundation Backups" pane (integrated in the TFS Administration Console) to restore team project collections to an earlier point in time, the databases keep showing up in SQL Enterprise Manager as "(Restoring...)"
      I did open the log of the restore and it confirms that everything passed successfully: no problem while restoring the full backup or the transaction logs...
      Am I alone to experience this with the Restore Database wizard ?
    • Did you get a chance to restart the SQL Services on the data tier after the restore completed? 
      (I am assuming you have Admin Console (App-tier) & databases (data-tier) on separate machines.
  • 谁能汉化一下
    1 Posts | Last post January 13, 2012
    • 我装的是中文版的VS2010,这个插件是英文的,现在我的右键菜单有些中文,有些英文,看着很不舒服,能否提供一个汉化版。
  • Powershell cmdlets don't get installed?
    3 Posts | Last post January 13, 2012
    • I ran the MSI installer on my x32 Win7 box, rebooted, launched powershell and ran "Add-PSSnapin Microsoft.TeamFoundation.PowerShell" and got the following error:
      Add-PSSnapin : The Windows PowerShell snap-in 'Microsoft.TeamFoundation.PowerShell' is not installed on this machine.
      HUH? Where does the dll get copied to during install? Am I missing a path element?
    • By default, the Powershell Cmdlets feature in the MSI do not get installed--if you want to use them you must choose a Custom installation configuration and explicitly select them to be installed.
      Also, I see you've specified that this happened on a 32-bit OS, but if you should happen to install on a 64-bit machine you'll get the same error unless you run Powershell (x86). The Cmdlets don't work in 64-bit mode for some reason.
    • Any luck with this? I have 2008 R2 server (64 bit) and trying to install the powershell cmdlets. When Install the power tools December 2011 edition, the setup runs fine if I choose to not install the powersheel cmdlets. If I choose custom setup and add the cmdlets to the installtion I get a 1001 Error and the install fails and rolls back.
  • Installer hides PowerShell option if you don't have VS 2010 installed
    1 Posts | Last post January 11, 2012
    • Kind of annoying. We have a TFS 2010 server, but we haven't upgraded our dev environment to VS 2010 yet.
  • December 2011 version - install errors
    1 Posts | Last post January 09, 2012
    • Installing Dec 2011 onto 2 new TFS systems, same result on both - 5 errors complaining about 5 different keys as noted below.  2 different persons tried it: local admin on Win 7 machine hosting a small TFS pilot environment, and a domain admin on larger production TFS environment - same result for both of us. Workaround was to hit "Ignore" and continue on - but I expect that Explorer context menus might be missing?
      Error 1406. Could not write value to key \SOFTWARE \Microsoft \Windows \CurrentVersion \Explorer \ShellIconOverlayIdentifiers \TfsOverlayControlled. Verif that you have suficient access to that key, or contact your support personnel.  ABORT | RETRY | IGNORE
      Then same for "TfsOverlayEdit", "TfsOverlayAdd", "TfsOverlayLocked", "TfsOverlayRename".
  • Team Members
    2 Posts | Last post January 09, 2012
    • I guess I am missing something (still kind of new to this).  I am an administrator for my team's project library.  However, for some reason I cannot see other team members in the Team Member node (I have it enabled in options).  I am able to control permissions and add/remove people from accessing our library, I just cannot see any team members through the node (it is not expandable).  I am sure it is something silly, but any help would be appreciated.
    • Hello, 
      Sorry for the late reply. Are you still having problems with team members ? Let me know if this post helps identify where team members get the list from :
  • Is it compatible with Visual Web Developer 2010?
    2 Posts | Last post January 09, 2012
    • Guys, I've downloaded and installed the Team Foundation Server Power Tools December 2011 update but not sure how I can start using it to connect to a Team Foundation Server? I have Visual Web Developer 2010 and a stripped down version of Visual Studio 2008 which was installed with SQL Server express but not sure where to go from here. Can you help?
    • Do you have VS 2010 Team Explorer installed ? Either as a standalone installation or as part of VS 2010 ?
      Youhana (MSFT)
  • Shell: Attempt to checkin a checkin-locked file silently fails
    2 Posts | Last post January 09, 2012
    • From the Shell menus, when I try to checkin a change to a file that has been checkin locked in another workspace, there's no error message. The file is obviously also not checked in.
      From the command-line I get a clear error message.
      Also, from the shell menus, if I attempt to checkout a file that has been checkout locked in another workspace, I get an error message (the same error I get from the command-line).
      Am I missing something?
    • Hello, 
      Thank you so much for reporting this issue. This is a known bug in the shell extensions. I have a bug already logged to address this issue in the upcoming release.
      Youhana (MSFT)
  • Is there a version for 64bit?
    2 Posts | Last post January 09, 2012
    • Hi,
      I am running TFS2010 on a 64bit Windows 2008 R2 machine. Is there a 64bit version of the power tools for this. When I try to install it says that TFS2010 is not installed.
    • I do run TFS2010 on a 64bit Windows 2008 R2 too (there is no x86 version of Win2008 R2) and didn't experience any issue to install the power tools. It is installed in C:\Program Files (x86)\Microsoft Team Foundation Server 2010 Power Tools.
      Are you logged on the server as a local admin ?
  • Crashing Issues
    1 Posts | Last post January 05, 2012
    • I have installed the December 2011 version and it has made Visual Studio 2010 Ultimate unstable when using Team Foundation Server functionality. I seem to be able to check in and check out OK, but trying to use Team Explorer is problematic. Any suggestions of finding a fix for it?
51 - 60 of 200 Items