Sitecore Rocks


Sitecore Rocks makes Sitecore developers happy. Directly integrated into Microsoft Visual Studio 2013/2015, Sitecore Rocks provides a fast and streamlined development experience with tools that developers are used to.

(49) Review
Visual Studio
2015, 2013
Download (100,631)
E-mail Twitter Digg Facebook
Add to favorites
Reviews (49)
Q and A (91)
Sign in to write a review
Sort by:

by Sandeep Pote | February 29 2016

by Sergii P | November 03 2015

by Praneeth Raj Rachamadugu | June 18 2015

Hi Team

I am facing an issue with SiteCore Rocks plugin installation, During the last phase of download of this plugin, I get an error .. Extension could not installed due to the below error, "Exception occurred during a webclient request".

Please help regarding this. I have verified and saw the WebClient service is up and running in my services list

JakobChristensen June 18 2015
| Edit |

Hi Praneeth

You posted both here and in the Q&A section.

Have you solved your problem?

by bUrak G. _ | February 26 2015

Great tool!

by Brett S1 | December 02 2014

Low rating because this extension is not open-sourced. Please open source Sitecore Rocks so we can evolve this extension and address the many issues still outstanding (e.g. file conflict resolution).

by Divamatrix | June 10 2013

Please explain where the documentation for this actually lives at? I can not seem to get it to do anything and all I'd like is some documentation. The Sitecore rocks wiki is amazingly void of anything even remotely useful at all. Is there something I'm missing?

Among the other many, many steps, I have walked through just to get it to connect, which I could write a book on, the one thing I really wanted to do was to generate entities from my templates. Every single time I try to choose "generate class" (there are 2 of them, by the way), it throws an error. It would be really helpful if I even know what I was doing in trying to generate classes from my templates?

JakobChristensen June 10 2013
| Edit |

Hi Divamatrix

Sorry to hear that.

Sitecore Rocks is currently in CTP which is why there is no documentation or official support from Sitecore.

Please post a screenshot to the exception, that you get, in the Sitecore Rocks SDN Forum, and I will see, if I can fix it.

John West has a nice blog series:

Trevor Campbell also has a nice series:

by Tony Bolton | June 04 2013

Really good - thanks!!

by Gorhal | January 18 2013

by kdeenanauth | April 05 2012

Great extension for Sitecore developers

by kodexe | September 16 2011

Didn't work on my Commodore 64.

by AndreasBergstrom | June 23 2011

by Commodore73 | June 20 2011

I wrote some blog posts introducing Sitecore Rocks. I definitely give it five stars.

by Ronani | June 16 2011

After dreamcore 2011 I am ashamed I didn't used it a lot :-) Ronald

by LarreLandin | June 13 2011

by GurliGebis | June 10 2011

Works great and makes developing for Sitecore alot easier and faster!

by GuitarRich | June 09 2011

Love the new features demo'd at DreamcoreEU

by Eldblom | May 24 2011

Exciting! Looks very promising - especially with the plug-in possibilities.

by JJRocks | May 19 2011

by pbering | January 27 2011

- 0.6.5 now with plugin repository, very nice!
- 0.7.2 is greatly enhanced, if you havn't tried it yet, now is the time!

by JigsP | December 14 2010

Awesome plugin. Thanks

1 - 20 of 49 Items   
Sign in to start a discussion

  • Version
    3 Posts | Last post October 04, 2016
    • Is it still possible to download version of the VS extension?
    • Hi Thad
      I am of course curious as to why?
    • Thanks for the response, but I had already checked there and the last version is
      The why is a few different things combined... I have non-developers using the standalone (Windows) version of Sitecore Rocks for running occasional queries (Rocks v2 doesn't have standalone). I'm also running VS2012 connecting to Sitecore 7.2 (neither are "supported" by Rocks v2), but I just had a new developer join my group and I'm not able to give him Rocks because the plugin version must match the server version (so the version doesn't work).
  • Issue with Sitecore Rocks on VS 2015
    4 Posts | Last post September 23, 2016
    • I am trying to download sitecore rocks extension on VS 2015 on Administrator mode from "Extensions and Updates" through online visual studio gallery. When I Search and download sitecore rocks extension I get this error "The extension could not be installed because the following error occurred:An exception occurred during a WebClient request.".
      Could you help me is resolving this. Thanks!
    • Hi Rakesh
      Are you having issues downloading Sitecore Rocks from Visual Studio Gallery?
      That I cannot help you with, but alternatively you can download Sitecore Rocks from AppVeyor:
    • Hi Jakob,
      I installed rocks from AppVeyor. It worked.
      Thanks for your help!
    • Hi Rakesh
  • TDS Connector
    2 Posts | Last post September 15, 2016
    • Apologies if already asked but can't see a way to search the Q&A section.
      I've been running Rocks version 1.5 for a while with the TDS Connector. I just tried connecting it to a Sitecore 8.2 instance and got a No Service error. Assuming 1.5 doesn't support Sitecore 8.2?
      I installed Rocks 2.0 and can connect to Sitecore, but there appears to be no plugins? I really love my TDS connector, is there a way to get it working with Rocks 2.0, or to have an older version of Rocks working with Sitecore 8.2?
    • Hi jofes2000
      It was a reported as a GitHub issue:
      Hedgehog is updating the TDS Plugin to support Rocks 2.0.
  • Hi
    2 Posts | Last post September 08, 2016
    • Using Sitecore Rocks
      Design Layout shortcut on earlier version is working with (ctrl + U) (I think).
      On latest version Design Layout with (ctrl + return) is not working, it just enter the item.
    • Hi Eugene
      Thanks for reporting.
      I have fixed this - and you can get a build here:
  • Query Analyser Import
    2 Posts | Last post August 28, 2016
    • Hi Chaps, I'm using the query analyser to import items from a csv file
      set contextnode=/sitecore/content/xxxx/Home/xxxxx;
      import csv file "c:\xxx\xxxx1.3.csv"
      I was wondering if there is a way to create a branch template instead of a template, when I point to my branch template I get 
      Item "/sitecore/templates/Branches/xxx/xxxx" is not a template.
      Is this just a case of the validation only checking the template type and not the branch template type or is it just not possible. 
    • Hi Andy
      Sorry, no I do not think that is possible currently.
      If you want, you could have a go at the code:
  • Choosing a icon no longer works
    5 Posts | Last post August 04, 2016
    • When I open the screen where normally all the possible icons are shown I no longer see any icons in any tab. Any ideas?
    • Using Rocks
      SiteCore version latest 8.1 
    • Hi Danny
      Sorry about this.
      Sitecore Rocks retrieves the icons from
      Unfortunately is not working at the moment.
      We are working on it.
    • Hi Danny
      Should be working now - thanks for reporting.
    • Yes its working again. Thx!
  • Error previewing items
    3 Posts | Last post July 05, 2016
      Whenever I try to preview an item by right-clicking and choosing "Tools -> Browse -> Preview" I get the following exception in th browser window: 
      CS0246: The type or namespace name `__ReSharperSynthetic' could not be found. Are you missing a using directive or an assembly reference? . 
      I am using version and visual studio 2015 
      How can i get it work! thanks!  
    • Hi Batistuta 
      As a work-around, you can manually remove it from the [YourSite]/sitecore/shell/WebService/Browse.aspx page.
      It is fixed in the next version.
    • It worked  after I removed it.
      Thanks for your reply, Jakob.
    1 Posts | Last post May 12, 2016
    • Hi all
      Please report any bugs and wishes in the GitHub repository
  • Error when opening Data Subfolders
    2 Posts | Last post May 12, 2016
    • When I try to open any Data subfolder (Debug for instance) I get an error "Could not find a part of the path c:\...\Data\ebug". The letter D is lost. 
      Same for any other subfolder
    • Hi Pavlo_id
      That is odd - are you sure you don't have a weird path in your web.config somewhere - I can't reproduce it.
  • Sitecore Rocks Over HTTPS
    2 Posts | Last post May 12, 2016
    • Our sitecore instance is configured to use HTTPS even in local work stations. Is there a way to originate the request from Sitecore rocks to be SSL or https? I could use the Good Old Web Service but I am not sure what features will I be missing if I use the Good Old Web Service over Hard Rock Web Service.
    • Hi Vamshik1
      I think you can just prefix the host name in the connection with "https://"
1 - 10 of 91 Items