Microsoft Visual Studio 2013 Installer Projects


This official Microsoft extension provides support for Visual Studio Installer Projects in Visual Studio 2013

(109) Review
Visual Studio
Download (283,765)
E-mail Twitter Digg Facebook
Add to favorites
Reviews (109)
Q and A (132)
Sign in to write a review
Sort by:

by Bringfireh | September 30 2016

A nice one really.

by Buddy94 | August 13 2016

Nice to have this back. I don't know why Microsoft would have taken it out of VS.

by nimblebit | April 14 2016

by Megadeth | April 07 2016

Thank you very much. I used it to install my service - Works great!

by André | March 16 2016

Exactement ce qui me fallait!! Merci

by Steven Owen | February 10 2016

by KerryDow | January 15 2016

I'm glad this was available.

The Flexera software installer looked slick and acted like it worked,
but the service would never show up in the Services list. Was driving me
crazier than I already am.

This worked and fixed my issue in 10 minutes.

by gurkenschneider | December 08 2015

by Claus Heimerson | November 20 2015

Heaping pile of dogshit.

There's almost no customization that can be done to the UI flow, my custom actions don't fire half the time and require me to delete them and recreate them. Now, its not actually uninstalling the main application on uninstall ( it does remove the entry from Add/Remove Programs, but the program files are still there and the application.exe still runs) - even though it reports no error.

Only reason for 2 stars is it's free.

by nkomp18 | October 28 2015

Installed fine but all existing projects stop working with an XML exception error. I had to uninstall in order to be able to continue working.

by DatPTVN | October 19 2015

Thank you

by Yatajga | October 12 2015

by tazlulu | August 04 2015

For VS2013
Why not copy the Microsoft (for vb in the 'C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\ItemTemplates\VisualBasic\General\1033' from vs 2010 and place it into the 2013 1033\general template area? That seems to work for me.

This trick however does not work for VS 2015

by Xian75 | July 11 2015

In win8.1 32bit
-cannot compile x32 services application.
when add two set of custom actions ( one for system\myDir1\service.exe , one for system\Mydir2\service.exe in the same project ) , no warn, no error.
Running the setup the custom action of service1 is executed twice ( I put a msgbox to check this) raising the" Error service already present" ( obviously).

in win8.1 64bit
-Cannot compile x64 service application.
Add custom actions (service install) in system64\mypp\service.exe . No warn, no error. Running the setup I get the error file "service.exe" not found

by GalayM | July 06 2015


by Antonariy | June 10 2015

Corrupts russian text in files and folders names.

by mnvlasov | April 27 2015

by Mohsen Alizadeh | April 21 2015

by Irfan Charolia | April 18 2015

I got Visual Studio Express 2013 for desktop. When I try to install Microsoft Visual Studio Installer Extension, it can't find Visual Studio and gives below error message:

"Stop Block: ProfressionalBlock : Microsoft Visual Studio is required, but it is not installed on this computer. Please install it and retry."

Means it doesn't support Visual Studio Express 2013 Edition :(.

by Steve Parrish | April 08 2015

I really missed not having installer projects in VS 2013. It worked great and as expected. Thank you!

1 - 20 of 109 Items   
Sign in to start a discussion

  • EnableOutOfProcBuild disappear
    1 Posts | Last post 1:06 PM
    • I also have to set the EnableOutOfProcBuild key to avoid the 0x8000000A error. But now this setting disappear in random intervals! I have to set this setting again and everythings works fine again. What could be the reason for this effect? Why are the registry settings disappear?
  • MSI installer custom actions caused error on install
    1 Posts | Last post September 22, 2016
    • I did simple windows form and console application and add Visual Studio installer project to the solution as well. Also I add custom actions to this Setup Project on install and commit, in order to run exe (that is part of installed application) just after installation finished.
      To install and commit I add main output files and turn Installer Class to be false. But when installation almost finished I got error - Windows installation package error. Unexpected termination of the program, which is part of the installation. Could you please advise the way to fix this error? P.S. Installation running perfect without custom actions but it's not starting exe on installation complete.
  • ManhBrown
    1 Posts | Last post September 12, 2016
    • When using Visual Studio 2015 for open Windows Installer projects created in Visual Studio 2013 by installing the Visual Studio Installer Projects Extension. What is effect may occur? 
  • RUn Microsoft Visual Studio 2013 Installer on TFS Build Server
    1 Posts | Last post July 14, 2016
    • Hi
      I installed Microsoft Visual Studio 2013 Installer on the build server 
      When i run a project that contain "Microsoft Visual Studio 2013 Installer" on my 
      TFS build server, I got the followed error
      "C:\Builds\6\Utilities\AGPS\Sources\Setup AgpsSevice\Setup AgpsSevice.vdproj.metaproj: The project file "Setup AgpsSevice\Setup AgpsSevice.vdproj" is not supported by MSBuild and cannot be built."
      When i try to build it using VS2013 on the build server the build succeeded 
      Build Server log:
      Build started 7/14/2016 3:29:59 PM.
      Project "C:\Builds\5\Utilities\AGPS\Sources\AgpsService.sln" on node 1 (default targets).
        Building solution configuration "Release|x86".
      Project "C:\Builds\5\Utilities\AGPS\Sources\AgpsService.sln" (1) is building "C:\Builds\5\Utilities\AGPS\Sources\AgpsService\AgpsService.csproj" (2) on node 1 (default targets).
        Creating directory "obj\x86\Release\".
        "C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\bin\Resgen.exe" /useSourcePath /r:C:\Windows\Microsoft.NET\Framework\v2.0.50727\mscorlib.dll /r:C:\Builds\5\Utilities\AGPS\Sources\AgpsService\DLLs\Sybase.Data.AseClient.dll /r:C:\Windows\Microsoft.NET\Framework64\v2.0.50727\System.Configuration.dll /r:C:\Windows\Microsoft.NET\Framework64\v2.0.50727\System.Configuration.Install.dll /r:"C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.5\System.Core.dll" /r:"C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.5\System.Data.DataSetExtensions.dll" /r:C:\Windows\Microsoft.NET\Framework64\v2.0.50727\System.Data.dll /r:C:\Windows\Microsoft.NET\Framework64\v2.0.50727\System.dll /r:C:\Windows\Microsoft.NET\Framework64\v2.0.50727\System.Management.dll /r:C:\Windows\Microsoft.NET\Framework64\v2.0.50727\System.ServiceProcess.dll /r:"C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.5\System.Web.Extensions.dll" /r:C:\Windows\Microsoft.NET\Framework64\v2.0.50727\System.Xml.dll /r:"C:\Pr
  • Installation fails on Windows XP
    1 Posts | Last post July 11, 2016
    • Hi,
         I've created an installer project but it fails to install on Windows XP even though I've got Windows Installer 4.5.6001.22159 installed. The error message is 'Installation Incomplete', 'The Installer was Interrupted'. Has anyone else had this and found a fix for it?
  • Installed but not seen
    1 Posts | Last post June 15, 2016
    • I got VS2008/2013/2015. I want to use this on my MSVS2013. I run extension, run well but when i want to try a sample, there was no installed extension. only 2 choises in there (New Project>Installed>Templates>Other Project Types).
      Setup and Deployment (includes known Enable InstallShield Limited Edition)
      Visual Studio Solutions (includes Blank Solution)
      What can i do to solve this? 
      I restarted VS2013. no solution. 
      I restarted my pc. no solution. 
      Remove/Install/Repair. no solution. 
      Any idea?
  • 0x8000000A Error in Autometed Builds
    1 Posts | Last post June 07, 2016
    • We are using VS2013 with the extention to create MSIPackages.
      Everything is working smooth from visual studio, but we are getting error (0x8000000A) when using TFS for Automated Builds.
      We had used the workaround by creating the DWORD value for HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\12.0_Config\MSBuild\EnableOutOfProcBuild registry value to 0. 
      But still facing same issue. We also had modified the same setting under S-1-5-20 (Network Service) account, as Build Service is running under this account.
      Please help to resolve the issue.
  • Source Code for MSVS 2013 Installer
    1 Posts | Last post May 17, 2016
    • Is the source code available for this Add-On?
  • error when compiling setup project from command line
    2 Posts | Last post May 05, 2016
    • I have a Setup deployment project which has been working and compiling fine  using both the GUI and cmd line.  I then edited the project to add some new registry entries on install. The project compiles with the GUI interface , but now will not compile via vs cmd ( 
      It comes up with these errors:
      ERROR: Unable to update the dependencies of the project.  The dependencies for the object 'Primary output from View.Client (Active)' cannot be determined.
      ERROR: Unable to update the dependencies of the project.  The dependencies for the object 'Primary output from View.Client (Active)' cannot be determined.
      ERROR: Unable to update the dependencies of the project.  The dependencies for the object 'Microsoft.WindowsAzure.Storage.dll' cannot be determined.
      ERROR: Unable to update the dependencies of the project.  The dependencies for the object 'Microsoft.WindowsAzure.Storage.dll' cannot be determined.
    • Did you get anywhere with this?  I am experiencing a similar issue.
      Our automated build processes (Cruisecontrol.NET AND Jenkins) generally fail when running command builds when the solution contains BOTH a web project AND a setup (vdproj) project.
      Logs seem to indicate that the web projects are not being compiled ahead of the setup project (there is no trace of anything related to the web projects in logs).
      All build orders are correct.
      Projects are configured to build in the requested configuration.
      Problem manifested subsequent to install of VS2015 / VS2015 Installer Projects on a build machine, which, up to that point built our software / setups without issue.
      Independent command-line MSBuild of the web projects succeed.
      GUI builds of the web / setup solution succeed.
      Manual, command line builds FAIL with the same error as the automated system.
      If anyone has any suggestions, I'd really appreciate some assistance.
  • Install this new verrison - install is not start
    1 Posts | Last post April 26, 2016
    • I do install this new version to existing VS 2013 on W10 PRO.
      I run the installer ws_bundle.exe. I checking agree checkbox and press Install button down on the install form. The installer not start installation. The installer nothing do.
      I may close the dialog, uncheck/check other checkboxes, but install is not start.
      Where could be the problem?
      Many tnaks for any ideas.
1 - 10 of 132 Items